Hass.io over IPv6

I still had the issue that I couldn’t access certain add-ons that use HA auth (like JupyterLite), but when I disabled ipv6 (by removing the server_host: ::0 in the config) it worked. @DavidFW1960 said that he got it to work with ipv6. Did you change something else to make hassio use ipv6 for internal communication?

I do use Caddy and the addons are all sub-domains but work over IPv6. My hassio only works via IPv6 address or IPv4 works internally as well.

Ok. I just changed to server_host back to work with ipv6 and now it works. Thanks anyways for helping.
I just noticed that this is only because it now has a cache for my credentials. As a workaround this is fine I guess.
For anyone who has the same issue:

  • Remove the server_host setting
  • Reboot (the whole system not just hassio)
  • Login via local ipv4 address and check that all addons are working
  • Readd the server_host setting
  • Reboot again
  • Now it hopefully works

Hi guys, I am trying again to get IPv6 running on my hass.io since I really woud like to have remote access.

I tried again to implement the steps described by @Zoker in his first post in this thread.

This is my RPi on my Fritzbox:

This is my port forwarding:

This is my configuration.yaml

of course I restarted hass.io and I get confirmation from my telegram bot, that it has started successfully. Unfortunatley I am not able to access it with any browser address.
E.g. if I try [2001:a61:3617:1401:3939:d631:XXXX:54e5]:8132
I get:

If I try
I get:

I think before I can not access my hass.io via one of these addresses I do not have to care about any other actions. I would really appreciate your help since I am out of options. If it helps PM in German are also possible or even via phone.
Thanks for your help in advance!

you have 8123 not 8132 in your router and config

Thanks. I corrected that…stupid mistake.

Unfortuantley it did not change anything. I still get the “refused connection” message.

The default hass port IS 8123… you need to open THAT one not 8132 and use 8123 to access the HA web ui as well

yes, sorry, thats correct. So here are all the settings for my updated, unsuccessful test_

the details of my RPi:

the port forwarding

my configurations.yaml http entry

and the response if I try to access http://[2001:a61:24b2:8401:3939:d631:XXXX:54e5]:8123/

Why are there 2? (top & bottom)?

Mine looks like this

Good question, Idk. @Zoker mentioned in his first post in this thread, that this seams to be the case sometimes. So I don’t think that should be a problem.
I really would like to know if the problem has to do with my FB and the forwarding or the configuration of my hass.io. I just do not know how to seperatly test these two things.

All I know is I have it working. I do use Caddy as a reverse Proxy and I have my duckdns address updatingthe IP address (which is moot as I have a fixed IPv6 address anyway but it allows me to use the domain name. Note this is different to the inbuilt duckdns in the Fritz)

I have port 80 and port 443 open (80 for LetsEncrypt certificate). I then use https://domain and that is port 443, Caddy sees that and says… oh domain - and redirects to local ipv4:8123. I also have a bunch of subdomains so eg config.domain - that goes through the proxy to localIP:3218 for the configurator etc.

I do have a step-by-step here for using Caddy.

Can you maybe try to swap out the the interface ID for the top ipv6 and see if that works? I’m also sometimes having multiple ipv6 addresses starting with 2001 and only one of them seems to work

Does your ISP block ports?

If you go to Internet>PermitAccess>Fritzbox Services it shows something like this:

Can you navigate to any of those using the addresses given? They are for the FB of course, not Hassio but just to confirm you can access externally…

Problem is that the assigned IP address for the device is the only one that will work anyway…

Hi, i use Unitymedia DS-Lite. My solution is OpenVPN on a synology Diskstation 24h/7d running. The IPv6 Adr. from the synology is forwarded with my fritzbox. An then i use feste-ip.net to forward the port 1194. (short version)

You should never do a portforwarding without https enabled. With http, your password is transmitted in cleartext. A VPN Solution enables you to use more services the only port8123 from hass.io.

Agreed but remember this thread is about IPv6 and there’s no such thing as Port Forwarding with IPv6.

It does but good luck getting Google Assistant to connect to Home Assistant over a VPN.

Hi @DavidFW1960, thanks for all the feedback, I really appreciate all of you guys helping!
I could not really find any menu item precisely providing your information. I have a FB 7490 that belongs to my ISP and stupidly they blocked the option to change the language.
I think the menu where this option could be is this:
however, as you can see, there is no “enable https” option. Also if you go to the blue link that basicly says “change connection properties” there is no such option. Could it be that my ISP blocks this option?

Well… short answer first: NOW IT WORKS!

When I checked the current IPv6s of my RPi, it was a completely new one. Until now the last 4 blocks have always been the same (as discussed somewhere above). Now they were different as well. So I updated the Interface ID and created a new IPv6 forwarding and now I can access hass.io over

But if the IPv6 changes again completley, I have to not only change the link in the browser, but also the Interface ID … is that correct?

And I also guess, that any external service (duckDNS or feste-ip.net) would require to at least have the last 4 blocks of the RPi IPv6 constant?
edit: I guess that is what duckDNS is all about :slight_smile:

Well… at least I am one step further! Thanks for that a lot! :+1:

So, after a little bit of research, I startet my duck DNS add in again and activated the DynDNS on my FritzBox.
If I now access myDomain.duckdns.org I get to my FritzBox WebUI and not to my hass.io.
My configuration.yaml input still looks like this:

  server_host: ::0

I guess I have to include the base URL and other information again. How do I do that without disabling IPv6?

You can’t use the FB to update duckdns address for Hassio!! If you use the FB one it will update it to the IP address of the FB not the Pi… this works for IPv4 because of Port Forwarding but with IPv6 you open the port and the Hass.io is directly accessible on the Internet.

What are you running hass on? Hass.io or HA??

There is a duckdns addon if using hass.io I use a script on my nuc to update duckdns…