HASS.io tab missing and ssh/samba no longer work

Upgraded to Hass.io a couple weeks ago and it’s fantastic but I can no longer get access through samba or ssh and the HASS.io tab is no longer on the left hand panel of my home screen so checking setup is impossible. I haven’t made a back up of my yaml files otherwise I would rewrite the sd card and start again.
Please help!

I had this happen to me as well while trying to exclude a zwave sensor. Not only did the hass.io item disappear in my case, I also got doubles of my zwave group and those that were auto-discovered. I ended up wiping everything and starting over as I had recently started building the config and everything was easy to rebuild.

You can turn on more robust logging which would probably be helpful to see. Setting up logger:

Just in case, do check that you’ve the following in your configuration.yaml:


and reboot, it should come back.

I’m having problems since the last update trying to connect to samba, all my other machines’ samba links work as normal, so I’m guessing this one is hassio based.

thanks frogbite but I have already put so much time into getting everything set up and working that starting again is just unthinkable, also everything is working well at the moment. I don’t understand what the “logger” does?

There must be a way to access my yaml files another way, perhaps direct from the sd card but I haven’t been able to figure it out

Bit-River I suspect that may very well be the cause for the HASS.io tab going missing but I don’t know how to access my configuration.yaml without samba access?

I access them on the pi directly by using ssh. I also have the terminal plugin installed for now, so I can access the /config directory from anywhere.

The logger is how you configure hass.io to log events, and it is very limited with its default setup. I have not played with it, but when this happened to me, that is when hass.io disappeared from the menu, I did not adjust the logger as I am not that far into setting anything up yet. So I understand that rebuilding is not an option, just saying, that is the route I took.

I hope you figure it out soon.

I forgot to mention, you can use the “Configurator” plugin as well to access the config files if samba is not working.

No luck here then… I’ll hang on to my SD card just in case I find a way to access the yaml directly but I’m starting a new SD image disk.

Urgh, what a pain in the arse but it’s a lesson to back up all the time!

Hi there, I am a newbie in home assistant, but I think I am facing a similar issue.

I had Hassio set up in a raspberry pi 3 last week. I set up four add-ons through the hassio tab of the web UI: samba, ssh, configurator and homebridge. Everything was working as expected from documentation. A couple of days ago I upgraded to the hassio 0.65.6 version and latter installed the mosquitto add-on. Everything was working as expected.

Today I have issues with the hass.io tab of the web ui. I see the link in the menu and I enter the dashboard ok (it shows the five add-ons I have installed) but the UI goes blank if I click in any add-on to try to configure/manage them. No error message, just blank. And if I try to click on any of the menus of the hassio tab (snapshots, add-on store or system) it goes to blank as well.

Additional relevant info is: my ssh add-on is working fine because I can ssh the raspberry. The mqtt is working fine because the switches that use the service work just fine. The configurator add-on works ok, I can access the config files just fine. The home bridge is working as good as I have been able to make it work (shows homeassitant bridge in apple home app) but the samba service is not working at all. I have not configure any zwave add-on at all.

I have try the following workarounds without any improvement in hass.io tab issue:
-review my config.yaml file through configurator and realised it did hot have the “hassio:” line as explained by bit-river, I included the line, restart the hass and the issue persists.
-reload the core configuration, nothing changed.
-restart the home assistant server, nothing changed.
-power cycle the raspberry, nothing changed.

Not being able to manage/configure the add-ons is very critical issue. Could you please help me figure out what is going on?.

I have my Samba back :slight_smile:

I went into the addon settings, changed the name of the share & restarted it.

All good now!

Worth a try if you’re stuck.