Hass.io Tab Missing In front end

I recently moved my home assistant instance from the hass.io image on a RPI to Docker on my Ubuntu server.

I used the command
docker run -d --name="home-assistant" -v /PATH_TO_YOUR_CONFIG:/config -v /etc/localtime:/etc/localtime:ro --net=host homeassistant/home-assistant
To install and run home assistant with hass.io which initially worked but some of the addons didn’t work (which I think is because hass.io installed the arm addons not the AMD64 addons) so I removed the Docker containers and reinstalled home assistant and hassio using the same command as before. However this time the hassio tab was missing in the web interface - meaning LetsEncrypt, DuckDNS and all the other addons are not able to run. However the Hassio container is running and can be seen in portainer.

Also I still have hassio: in my configuration. I have managed to change the config so I can access homeassistant locally, and I can control my devices through Alexa and through the web interface when on my LAN but I would like to get hassio back up so that I can get my addons working and use it for other useful things (such as updates and snapshots).

If anyone knows how to fix this any advice would be greatly appreciated!!

You’re running home assistant not hassio.

Remove the 2 containers you have because they aren’t running correctly.

Use the Linux generic installer for hassio.


Which instructions are you referring to for the generic linux install? I have tried using the instructions here:

which installs a hassio container but no home assistant container. I can’t connect to the web interface on 8123 and after port scanning the server I’ve found no new ports open.

Try here

Just followed those instructions and had the same problem - it only installs a hassio image, not home assistant