HASS.IO to standard home-assistant

I have a Synology NAS. I originally setup HASS.IO and setup Home Assistant, NodeRed, HACS, and all my devices. I applied the temporary fix to upgrade HASS.IO after DSM7 broke everything. However, for quite some time now Home Assistant has been flaky. The Supervisor Docker keeps crashing, and stopping NodeRed too. All this means the Home Assistant intermittently doesn’t work. So I decided to remove the HASS.IO that Synology kept complaining about. Beforehand, I backed up the system through Supervisor, and downloaded it, exported all steps in NodeRed, and took a copy of the RAW Layout. I then uninstalled HASS.IO, and it removed most of the docker containers. I removed the rest manually.

I then installed homeassistant/home-assistant and nodered/node-red Images, setup the containers, and did an initial configuration of Home Assistant. However, I cannot install any add-ons. I connected to NodeRed and imported the export made previously. However, whilst I can remember many of the Palette elements to install, I cannot find them all, and so they won’t work.

I tried restoring my final backup from HASS.IO, but HA Settings Backup has no restore function. I’ve tried manually copying the backup back, and hopefully restoring the backup manually, but when I view the TAR, it’s full of other TARs.

Is there a guide to move HASS.IO to non-HASS.IO Home Assistant, or any advice?

Thanks in advance.

Yes it does. Click on the backup in the list. In the pop-up window there is a restore button bottom left.

Thanks Tom, but not for me

You will then see something like this:

Thanks for the prompt response. But still no joy…HomeAssistantBackup - YouTube

Click the three dots icon top right of the backup page and select “RELOAD”. Then try again.

I assume you mean reloading the browser page? I’ve tried as standard reload, and a reload without cache. I’ve also stopped and restarted the docker, and tried an InPrivate session

No I mean want I said:

Hass.io” doesn’t mean anything. Neither does “non-hass.io” or “standard home-assistant”, none of those are installation methods. Please tell us how you installed HA so everyone is on the same page.

Tom is showing you how to restore from a backup when you are in a supervised or OS type installation. If you did a container or core type installation then HA has no options for restoring a backup made by supervisor.

In a container or core type installation what you can do is copy the contents of your config folder to the folder you’ve chosen as the config or homeassistant folder in those setups.

1 Like

I forgot that other install methods have backup now.

HASS.IO is a Synology available application that does a supervisor install of Home Assistant. It appears to install quite a number of docker installs of various components, including home-assistant and supervisor. The non-HASS.IO install refers to the docker image of Home Assistant alone referenced in the original post

I then installed homeassistant/home-assistant and nodered/node-red Images, setup the containers, and did an initial configuration of Home Assistant.

I have no issue with blowing out the current install. which is now in a semi-working state e.g. node-red works but is not integrated into the Home Assistant interface. Quite a number of the integrations are failing, and I’m having to manual rebuild them.

All I wanted to do, was to have the Supervisor and Node-Red dockers not crash constantly, and Synology Package Center stop telling me that HASS.IO package was no longer supported.

I hope this makes some sense

I should add, I loved the Supervisor version, and how it was originally setup was great, apart from the crashes. Although I’m not sure that is possible on a Synology DSM7 NAS now

I’m not really familiar with Synology but if it tries to do a supervised install then it’s almost certainly not a supported one. Supervised installations are only supported when done on vanilla debian with no additional software or containers installed by something other then supervisor. So just the fact that you have some software running already which is doing a supervised install for you suggests to me that its unsupported. I also highly doubt it is a vanilla debian OS.

This only happens in either a supervised or OS install. Both of those types of installs require you dedicate either an entire machine or an entire VM to HA. Nothing else is installing or managing software or containers in that system other then HA. If you are just trying to install some containers in an existing system with other containers already running then you won’t be able to achieve this. Your options are either:

  1. Run an HA container and a Node RED container separately and manage each yourself. Each will have its own interface like normal. They can communicate as long as you set up the networks correctly to allow them to do so.
  2. Switch to an HAOS or Supervised install by dedicating either a machine or a VM to it. Then you can install Node RED as an HA addon and see it integrated in the interface via Ingress.

Yea the mere fact that you have something called “Synology Package Center” managing containers says to me that you should not have supervisor. If you do you’re definitely doing something unsupported and going to have issues.

See if there’s a VM option, you can install HAOS in a VM. If not then you should just do individual containers for HA and Node RED and not supervisor or you’re doing to have a lot of issues.

For some reason the Synology version does not have this option. I am moving a backup from a supervised Debian 11 install to the Synology. I have experienced the same issues as the OP.
On my Debian 11 install there were the three dots in the top right corner of the screen, they arent there on Synology Docker version.
On my Debian 11 install I could click on a backup name and choose the restore option, clicking on the file names does nothing in the Synology Docker install.
Does anyone know of a different way to restore backups? I have far too much config to rebuild from scratch so I really need to restore a backup.

I installed to the Synology using these instructions: Alternative - Home Assistant
Im experiencing the same issues as robf_uk.
Restoring backups to my supervised Debian 11 install was simple, but those options dont seem to exist on the install using the above instructions.

The dot menu is missing from the Synology install.

Apparently as a new user I cannot upload more than one image per post so I have to break this up

This is my old Debian 11 install with the dot menu.

Clicking on a backup in Debian 11 install gives this menu:

On the Synology install it does nothing if you click a backup, they arent links that can be clicked on, just a list instead.

One other thing I noticed is that in the installation instructions it mentioned to search the docker registry for “homeassistant/home-assistant” this brought up two options as per this screenshot.

It doesnt seem to have changed anything adding the CLI option though.
Does anyone know another way of restoring the config? my install is fairly complex and it would be a massive pain to build it out from scratch again.