HASS.IO -> transfer from SD card to SSD or USB

Hi. I’m trying to migrate my Hassio installation from SD to ssd. I have a raspberry pi 3B+, running Hassio 0.103.5. I restored a backup to a USB key and to a ssd connected by a usb-sata adapter. I downloaded bootcode.bin file and put it on SD card. When I try to boot, it doesn’t start. On screen I see “**No partition table - mmc 0 **”. What can I try? Thanks

Edit: Ok, fixed, obviously my fault. I was still on HassOs 2.11, after updating it, USB boot worked. No sd card with bootload.bin file needed.

Just curious is Hass.io getting update include Raspberry 4 ssd boot any time soon? I think i wait that time that feature is included hass.io installer after that buy that cheapest raspberry 4 and attack my old intel 80gb ssd that and finally not need to thing how long memory card last this time :slight_smile:

Imho, of sd card life is a driving concern, pi3 is the way to go for now. As said before, hass pi4 USB boot workarounds are not an appetizing project for devs, and (like pi3 when it first released) pi4 will get proper usb boot firmware soon enough. I feel that Pi4 ha is best left for the devs at this time… by that I don’t mean everyone go buy a pi4 now and start bugging devs for usb boot, lol!

I boot firs part from SDCard. But rest is on a SSD card (ROOT). Run smooth for me on RPi4!!
I rsync the root (SSD) to not used root (SDcard) when ssd of HA crash for some reason i can change cmdline.txt so it boot from root of SDCard. Rebuild SSD and rsync back the root (SDCard) to root (SSD) and change cmdline.txt back. And we running again from SSD


I’m running HASS.IO on tinkerboard with sdcard. Do you think that a ssd and an adapter like the ones you use on RPi3 are good to go for a tinkerboard?

Was there any extra code needed or was it as easy as using etcher to load the Hassio image onto the SSD rather than SD?

No any code is required, just use balena etcher or whatever and grab it to your USB or mSATA drive. You can try, you will not damage your config. And then just restore your snapshot.

Hi there, I’m giving this a try with a Trascend 120GB SSD drive. I’m using a RPI3B+ so no need to fumble with files as USB boot seems to be enabled out of the box.
I flashed HassOS 3.7 onto it using etcher and attached the drive to the RPI3B+. Nothing. No reaction. The RPI replies when I ping it but I just cant troubleshoot what is going on as I can’t neither ssh nor http into it. I suspect the drive may not be compatible but I just can’t confirm it 100% as I have no visibility.
Could somebody help me figure out what is going on or point me in the right direction?
thank you!!!

First boot might take a while to resize/upsize the filesystems and download/pull docker images from the internet… wait 10minutes, you will see a “please wait” screen on http://123.456.789.012:8123 (replace with ip/hostname that your raspberry pi got from your router, but keep port 8123)

thanks @risk, good point! I had completely forgotten that in order to be able to see the installation process one had to physically hook up a monitor to the RPI. I feel dumb :slight_smile:

I just hooked up a monitor and started the process from scratch. When the SSD is connected and no SD card is installed, I simply don’t see a single output on the screen. As soon as I switch off the RPI remove the SSD and reinsert the SD card, everything goes back to normal.

Any idea how to troubleshoot this further?

many thanks!

@Magren did you ever figure out what your problem was? I also use a RPI3B+ and the following set up:

I’m about to pull the trigger and order a Crucial SSD drive but would rather prefer to use the one that I have lying around.

I imaged today an old 8GB memory stick as per @DavidFW1960 suggestion above, and the RPI did boot up. I could see lots of outputs displayed on a physically connected monitor.

To make matters a bit more weird, when I try to boot off the 120GB SSD drive (and nothing happens - not even a single line being output on the screen), not even a USB keybarod seems to be recognized because not even the CAPS LOCK led comes on when I press on it.

Any ideal?

Well, for me the problem was that i had a Rpi3B and not a 3B+ :blush:
Så i quickly ordered a Rpi4 and will continue with SD until they get the usb-boot sorted out and then try to switch.

If you use a 3B, just follow the docs on the RPi site to enable USB boot and set the OTP bit on it. Both of my Pi3B’s boot from USB.

@DavidFW1960 any idea on how to troubleshoot what may be going on with the SSD drive I’m trying to use with my RPI3B+? I posted some information a couple of messages above this one here

No clue… some USB SSD’s work some don’t… have you looked on the Raspberry Pi forums for help?

No, not yet. It definitely makes sense now that I think it through. Thank you.

Link to those docs?

@kitus, have you tried the bootcode.bin trick? That often works on the more ‘reluctant’ ssd setups. If you can’t work it out, be sure to refer to the hardware list posted above and pick out a good one.

That said for HA, almost any crusty old ssd will probably be good enough. No need to leave an ssd collecting dust if it can run HA.

First result.


Following David’s advice above, I raised a question in the RPI forum and they pointed in that very same direction. I tried it yesterday but it does not seem to be the solution, or I’m made a mistake at some point. I really don’t get it.

Even with an SD card holding that file I keep experiencing the same:

  1. It refuses to boot
  2. A connected keyboard won’t react - CAPS LOCK won’t come on when I press on it

I hate to lose my time fumbling around stuff that should work easily. And it annoys me even more that a USB stick is working fine.