Hass.io Unable to ssh in after reboot

can confirm that everytime I use SSH to reboot hass.io will come back just fine except that the SSH addon hasn’t started!

so yea sucks.

Tomorrow I am going to install this: Home Assistant Community Add-on: SSH & Web Terminal

hopefully that works better…

its still happening and I would really really love it for this openssh addon to properly boot after a putty reboot command!

@dimmanramone make a issue on hassio repository with supervisor logs after the bug is see on your system.

The last supervisor slowdone the startup and should help to manage slow hardware better without hit the hole system during boot.

Lately seems everything to work without any problem :slight_smile:

this is still happening. just installed hassio 2 days ago, and ssh won’t be started upon reboot. Do I really need to disable to official SSH and install it from a different repo to get this working? thanks

Same problem with a raspberry py 3. It’s impossible to connect after a reboot. Erro: connection refused in browser and by ssh. I will return to the hassbian. It’s very better to understand what is wrong.

This whole thread is surprising. SSH has been around for decades now and it is a very stable Service in Linux which starts during the boot process effortlessly. Can’t understand what is making this happen.

Same problem here: after restarting HASSIO SSH server does not start, although it have the “Start on boot” oprion enabled.

Looks like it’s still totally broken. The issue is 9 months and nobody cares?

1 Like

Yep I’m getting this too. Pain in the hass!

I found that if you run ‘reboot’ from the command line in HassIO (ie: when connected via Putty or whatever) then SSH will fail after the reboot, however if you power cycle the RPi, it comes back to life. After finding out that I no longer use the ‘reboot’ command and instead use the ‘restart’ command from within the config GUI. That doesn’t break SSH


Does the restart command restart the whole RPi or only Hass.io?

Depends on the command you use.

hassio ho reboot will reboot the Pi
hassio ha restart will restart home assistant

1 Like

Thanks, always using hassio ho reboot from now on. This makes Hass.io run back up.