Hass.io Unable to ssh in after reboot

Installed Hass.io on an micro card. Put in Raspberry pi. Booted, no issue.

Using the add-on feature, I added SSH, and configured with password, Tested and worked.

Went to the config folder, changed a few things in the configuration.yaml, clicked the restart option…HA hung. Would not come back. SSHed back in, tail -f the logs… nothing comming up.

Reboot Raspberry Pi…cant ssh in, web UI not comming up. tried the SSH with hassio.local and with IP address, neither allowing connection. port 22: Connection refused.

What can I do now? Since the screen only shows the Hass.io logo, Im stuck. Do I need to reinstall the HassIO OS? how can I access the PI with no ssh?

You figure anything out here? I’m having the same issue!

What kind of hardware do you have?
I think you system run out of space or the IO controller is to slow.

I just scrapped the whole idea of hass.io. I installed Raspbian and used the all in one installer. Everythings working much better that way.

1 Like

Same here. I even did an entire second reinstall of hass.io and went very slowly to make sure I wasn’t doing something wrong, but no matter what I do I can’t SSH into the Pi, it won’t load the frontend, and any configuration changes I make over Samba (which still works) don’t get the thing to boot. Looks like it’s back to Hassbian for me until this is a little more fully baked.

1 Like

Same issue here too

I scrapped the whole idea. I went with the “all in one installer” which seems to be working great. The hassbian is a has-been OS. good attempt. but just not ready for production.

1 Like

What is your Hardware? I see problems with too many add-ons on a raspberry pi A… They is limited to use 1 add-on and not too many components on home-assistant side

Raspberry Pi 3.

Same here. All worked fine until I rebooted the PI 3 via hassio. It seems stuck. I can’t SSH or Samba to the PI.
I can ping to the Pi. The activity led does blink every one or two seconds, but it has been doing that for quite a while now.

Same here.

The Pi is and I can see on my home lan network but I’m unable to connect to fronted or to ssh.

hass.io has been just a series of struggles. Going back to hassbian.

1 Like

Same issue too
raspberry pi3 and hass.io

going back to hassbian too…

i noticed that after restart, ssh is not starting automatically, even if the add-on is configured to start automatically.

try to login to the web console (for example http://hassio.local:8123) and start the server from there - then you will be able to connect via ssh

1 Like

ver 0.55.0
Pi 3b

Did this just happen to you? Same specs here and my Pi just shutdown on its own recently and now Hass.io is completely unresponsive. Can’t ssh or anything.

This was several months ago. I have not retried it since then.

Tried again yesterday.

Worked for a while. Now Hass.io is not responding and no SSH or SAMBA works.

I think it was a good idea. But I don’t know if I’m unlucky or what…

In the same boat too. I restarted and the SSH Server is not responding. I guess it never started after the reboot. I can surf though with not problems in hass but hass.io menu is gone, so I cannot start the ssh server.

Update: It seems that sometimes works and sometimes don’t, but I can always start it from the hass.io menu not that is activated.

It seems that the ssh plugin is a little unstable. Even if is set to auto boot. It doesn’t always start. Did anyone tried this plugin instead and had better luck?