Hass.io v66.0 unavailable after upgrade

I upgraded from v66.0 b3 to the official v66.0 release this morning and it seems to have reset/broken something because I no longer have access to my system. I tried to connect via SSH as well as http and my system is unavailable.

Have you tried a power off and on yet?

Yes, four times so far. The Raspberry Pi is visible to my router, I just can’t reach it through normal methods. I just connected a video cable directly to the pi, rebooted again and so far all I have is a nice splash screen for hass.io. I’ll give it a few more minutes just in case it’s busy doing something important but it’s not looking good right now.

2 Likes

I’m having the same problem here, upgrade from 66.0b2 to 66.0 final and I have lost the web interface

Edit - seems to have come back after a hard reset (Raspberry Pi 2).

I’ve noticed the Hassio page is blank when I try to view it. I refresh the web page and it usually shows up. Noticed this in .65.x as well. Am I describing the same thing (except I seem to be able to work around it)?

Similar. I was initially able to view the side panel but the main body showed that I was disconnected. I ended up rebuilding my system with a clean version of 66.0 and my system is back up.

Actually, its not blank I get the blue header and sub-tab options, and the word Add-ons, and the rest of the page is blank until I refresh. Also, I can’t view any of the other tabs (nothing happens when I click them, except some white underline seems to move around some).

Again, I refresh and it all starts to work then. Just sharing, in case anyone else recognizes this too.

[update]: My issue appears to be related to Safari browser on my Mac. Chrome does not exhibit this issue.

Any advice on rebuilding? I can flash the microSD card but I’m unsure of the restore process from a backup file. Enable Samba, copy over zip file, restore via web interface and reboot?!

Same here. Upgraded from 65.5 to 66.0 by clicking the hassio upgrade button and now the front end is gone (as in no http response at all).

SSH doesn’t work because the RSA host key has changed (could be unrelated: I’ve been using the front end for everything and haven’t used ssh in a while).

I’ve tried rebooting, including after creating /config/custom_components/hassio.py with:
curl -d ‘{“version”: “0.65.5”}’ http://hassio/homeassistant/update
because I read that helped people when there was a similar looking issue with 60.1.

Are there any alternatives to looking for my micro-sd adapter and reflashing?

All I have ever done is copy my .yaml files to my windows box, get the latest image from the home assistant web site, install the new image and put my saved files back on the raspberry Pi. It’s probably not the best way to do it but it has worked for me.

1 Like

I forgot to add a couple more things.
I keep a text file containing my duckdns information on my desktop because I’ve messed up my system more than once.
After the installation is complete you will need to install the samba and in my case duckdns add-ons to be able to copy the yaml files back.
As I said, it’s not as elegant as what other people do but it seems to work for me.

1 Like

Thanks for the details, much appreciated. I’ll give it a go when I can find my microSD adapter to flash it :slight_smile:

No flashing needed: the error log (viewed via Samba) showed a configuration error.

I had tried to hide some sensors (weeks ago!) but used incorrect syntax/sensor names. Lesson learned: hit ‘check config’ before doing an update.