Hass is running but no web gui

Well, rebooting my router didn’t do the trick. HOWEVER. I realized that my LetsEncrypt cert did not auto-renew. I had to delete the cache in my browsers, renew the cert and now all is well!

I also was tearing my hair out. When I logged into DuckDNS.org the IP address of my domain had changed. I changed it back to my HassIO IP and hey presto - it works.

I’m back in the same situation as my post a few back, for no apparent reason. Can SSH to HA box. Home assistant itself is running in venv, and LSOF shows multile TCP connections from hass to various componest google homes lutron etc. however HASS nor anything else is listening on 8123. Tried rebooting HA box, and Access point with no change. Totally baffled. No errors or warning is ha log. What would allow ha to work totally normally except not start listening on 8123?

1 Like

Just to check the obvious, you have to define the frontend component in your configuration.yaml

1 Like

Thanks for mentioning the obvious. But figured it out. By putting it in docker and removing the configuration.yaml file. Ok web interface. Restore original config file and start commenting stuff out one by one and then checking. After an entire wasted day I found out that this is what was stopping it.

device_tracker owntracks:
platform: owntracks
max_gps_accuracy: 200

Commented that out and boom starts working like normal with both docker, and venv.

Now keep in mind this hasn’t been modified since I first set up HA, literally months. Not sure where to post this but i think i need to open an issue for development. There is no way, that something that changed on the HA side or owntracks side, or any side for that matter, should completely BLOCK the web server from starting. No way a causal user would figgure this out.

I believe the owntracks component changed completely in 0.84, and that configuration is no longer valid.

I just updated Home Assistant as requested by portal. It then went into a reboot… and GUI never came back.
Thanks to this thread I solved the issue and here is how. I know almost no linux command but using “find” and “nano”, I managed to modify configuration.yaml file which contained, who knows why, a “*” (star) character on last line.
I installed Ubuntu app from Microsoft Store (search for “Ubuntu”) and then SSH to my raspberry box.
Using “find” command, I found “home-assistant.log” file which was complaining about some bad characters in configuration.yaml file.
So, using “find” command, again, I found configuration.yaml file, which I edited using “nano” command. I spotted this extra character at the end, which I deleted from within Nano editor.
Then using “hassio host reboot” I rebooted HA and after a bit, GUI responded.

I never rebooted anything else like router or access point.
Hope this will help another Linux noob (which I am).

You can use just PuTTY also. ;). You don’t need to install the entire WSL


Hi, I used to use this forum as a reader, but it is time to say hello everyone :slight_smile:

I had similar issue with HA. Everything seems to work fine except UI. Addons, samba, etc. works.
I tried severals actions: reboot from comandline, restore last backup - it didn’t worked. Logs were ok too.

In my case the problem was in configuration yaml file. I figured out that I changed yeelight IP address and forgot one sign -> “:”.

I just had the same issue, my wife unplugged the RPI and the web gui would not load.
I could SSH in and I could load the Cloud( ide.
I got it to restart by stopping HA through SSH and deleting the home-assistant_v2.db file. And then starting HA through SSH.

Now my v2.db file was only 126Mb and I have a 64Gb card and my log is set to only save 7 days.

But anyway took 4 days to figure this one out.


This worked for me. SSH’ed into the server, then opened a terminal to the docker container, renamed the home_assistant_v2.db file, and the system took off immediately recreating the database and starting the GUI.

Thanks vkeiper!

Nice! worked for me too :pray::call_me_hand:

Why the extra step of going into the docker container? All the files are there on the host.

Try a VPN on your browser ,tedaaaa !!

I am running into the same issue and it is driving me crazy! Process runs, but no UI. No error logs, only normal running logs. Everything works, except UI.

Deleting the DB is not an option. Any idea why is this happening and how to debug further?

pi@homeassistant:~ $ sudo netstat --tcp --listening --programs --numeric
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0* LISTEN 1293/python3

Restarting the router is what made mine show up on my Windows PC. I’m still not clear on why it doesn’t let me pull up the same page with the Raspi. Maybe the page can’t be accessed by two computers/browsers?

registered just to post that the solution by vkepier worked for me

rm /mnt/data/supervisor/homeassistant/home-assistant_v2.db

How do you run these commands? The SSH login password is unknown and the direct access has only the HASS’s “enter login” screen. Where do you put these commands?