HASS OS Generic_x86-64 500 Server error

I saw there are several open questions on users getting a 500 Server Error with Netgear Nighthawk routers. I did not see a solution.
I also tried ha> supervisor update on my Lenovo m910s with 8gb RAM and 256GB SSD with no success.

I keep getting:

[supervisor.homeassistant.core] Error on Home Assistant installation. Retry in 30sec
[supervisor.docker.interface] Updating image ghcr.io/home-assistant/generic-x86-64-homeassistant:landingpage to ghcr.io/home-assistant/generic-x86-64-homeassistant:2023.10.5
[supervisor.docker.interface] Downloading docker image ghcr.io/home-assistant/generic-x86-64-homeassistant with tag 2023.10.5.

[supervisor.docker.interface] Can't install ghcr.io/home-assistant/generic-x86-64-homeassistant:2023.10.5: 500 Server Error for http+docker://localhost/v1.43/images/create?tag=2023.10.5&fromImage=ghcr.io%2Fhome-assistant%2Fgeneric-x86-64-homeassistant&platform=linux%2Famd64: Internal Server Error ("Get "https://ghcr.io/v2/": net/http: request canceled while waiting for connection (Client.Timeout exceeded while awaiting headers)")

I am new at HASS and Linux.

THank you in advance,

I’m getting this same error and have a Netgear Nighthawk router! Did you ever find a fix?