Hass OS on Unraid VM won't start

So I just updated to 6.9 stable on unraid and my HassIO VM refuses to start-up due to a missing USB, all other VM’s are working fine.

I believe I know what the problem is:

  • I had an Aeotec Z-Wave USB stick plugged in to test Z-Wave JS, and later removed the integration and the add-on from HassIO.
  • Returned the USB stick back to Amazon
  • Restarted HassIO many times after that
  • But NEVER rebooted the VM

Now it looks like the VM is looking for that USB to restart but I don’t have it. So does anyone know if there is any way to restart the VM without having to recreate the VM and restore from a saved snapshot?

Or if this isn’t the issue any other ideas to resolve are more than welcome.

Thanks in advance.

I believe that if you edit the vm configuration by going to the top right corner and clicking form view, you can remove the offending piece of code of the USB stick.

I had to do this with another vm I run when I changed scanners.

Hope it helps,

1 Like

Thank you. Did not even think about editing the xml till you mentioned it just now. Will try and see if I can find and remove the line(s) pertaining to the usb and restart. Thanks again.

Edit: Removing the hostdev block for the USB subsystem in the xml config and restarting worked. Thanks again @carltonb