Hass remote access problems

Im trying to access my HASS server on my external ip and the port 8123 but i can’t get trough. On my internal adress, 192.168.0.xx and port 8123 is everything works fine. Accept if i try to change the port number in configuration.yaml to “serverport: 80” then it also stops working…

Have followed the guide of https://home-assistant.io/docs/ecosystem/certificates/lets_encrypt/ and opened the ports on my netgear router CG3100 following the router guide for port forwarding. I have have HASS installed on Rasbian lite.

Got to about 10:25 in this video (https://www.youtube.com/watch?v=nMjwJCYom9M) then the port seams to stop me to go any further.

Have searched the web and found different guides that tell me that me the same thing and that it should work… but it don’t…? I can’t find what I’m doing wrong.

How do i test my system to find whats wrong?

What ports do you have forwarded in your router? Do you have SSL traffic from your outside IP forwarding to port 8123 on your HA installation?

In other words, do you have traffic coming in on port 443 routing to the IP and port 8123 of your HA host?

Kind of new at this but this is what i got so far.

Have not gotten to the part with setting up the SSl traffic.
On the router i got it forwarding 443, 80 and 8123 to the HASS local Ip.
So if i got it right it should be open…? but i can’t confirm that they are open. When i go to “port checking” sites they all say that they are closed.

Did you create a custom rule for port 8123?

Yes, this is the settings i got.

1 Like

Another question.
I also got problems setting up the static IP adress, i got no internet access from the RPI after trying that on the “/etc/dhcpcd.conf” file, so i changed it back. But as I’ve read on other threads this should not matter sins i have the router set up to give my RPI specific internal IP adress every time. in my case

Can this effect the ability to access the HASS from my external IP?

It shouldn’t as long as .16 is the current IP of the Pi.

I just testep using 8123 and it works.

Who’s your ISP?

Did you try http://public_ip:8123 from outside your lan?

You can try using your phone while NOT connected to your WiFi.

I have seen situations where ISP’s block dual traffic on the same connection.

Tried with my phone on 4G, but no luck.

ISP is Comhem a swedish provider. And the router / modem is there. Have also been in contact with them, but they siad that: " sorry, i don’t got any training in port forwarding" So that didn’t help… :stuck_out_tongue:

any way to check if they block it?

You can temporarily port forward port 80 to the netgear and try connecting to http://public_ip

You can also try putting the Pi in the DMZ, just for testing, you won’t want this as a permanent solution.

Tried this as well, one more time tonight, still no luck :sweat:

Can i be a hardware problem…?

I’m having the same problem here and it appears we both have the same router/modem model, from your screenshot. Did you ever get it fixed?

John, replied to your other thread. If this is what your interface looks like, then I think my theory in that thread was correct.

Should be a custom rule with the start port being 443, the end port being 8123 and the local IP being your HA server.

Sorry guys, haven’t solved it yet. And have also tried with routing the port 443 -> to 8123.

Think it got something to do with the way my ISP set up the router for remote access, so it forces all the traffic to port 443 to the remote page, and don’t let it through to the HA server. Have changed my isp router/modem to a 2-3 generations later version, so its not that… :unamused:

Did you have a look at what I did here?
Have you tried https://example.duckdns.org:8123 (note: adding :8123)?