Hass --script check_config Command not Found

When I attempt to run the check config script according to this page I get:

[email protected]:~ $ hass --script check_config
-bash: hass: command not found

Is there something im missing?

You need to active the virtual environment.

Is there instructions on how i would go about doing this?

Thanks for the help, but I am still getting the same error:

[email protected]:~ $ hass --script check_config
-bash: hass: command not found

You have still not activated the virtual environment.

Maybe i’m not understanding things properly. Are you saying that every time i want to run the check config script, i need to do:

sudo -u homeassistant -H -s

source /srv/homeassistant/bin/activate

hass --script check_config

I can’t imagine this is the case, as I’ve seen videos of multiple people run the command without the virtual environment active. Such as: https://youtu.be/NHYv8Fn20qI?t=262

1 Like

That is what I’m saying :slight_smile:
those people do not have a virtual environment.

gonna become a little impopular on this forum, but 70% of the help supports here are for advanced users.

I do my bit of programming for work, amongst other things, but none of the commands on this topic work for me.
I am looging into hassos after that took me ages to configure, and now I ssh to p 22 or 2222, I write “login” or not to access the os or to stay in ha command line, but there’s no way in the world I have a “hass” command or a “homeassistant” command… or even a “sudo” command for that matter.

any help for dummies would be greatly appreciated!