HASS won't boot on RPI4

I just tried installing Home Assistant for the first time on my Raspberry Pi 4.

After flashing the Micro SD with HAOS 9.4 from here for Raspberry 4 64 bit and starting the machine up, it won’t connect to the router. I checked the router and it doesn’t get an IP. The green light flashes irregularly, indication it’s doing something. To check the card, I flashed Raspberry OS on it which works flawlessly.

I tried both the 32-bit and 64-bit variant. I also tried the previous version, 9.3. I tried a different MicroSD card. In all cases the same result: The lights are coming on, but the device doesn’t get an IP. I’m not sure if it’s doing anything at all.

Any hints?

If you have a screen, try and connect it on the HDMI port. Will show the boot sequence, if it boots at all. Might give some indications on where it fails.

Got it! It was a broken power supply. It provided just enough power for Raspbian to start up, but HAOS is a little more power hungry. As soon as the device couldn’t get enough power, it rebooted.

Fixed by replacing the power supply.