Home Assistant Community

HASSbian and Aeotec Zwave Stick Issues

zwave
Tags: #<Tag:0x00007f3751d638c0>
#1

I am at my wits end. I’ve tried for weeks and have searched tons of articles and tried many different things and I can not get this zwave stick to work.

My current specs:
I am running a new Raspberry Pi 3B+ and hassbian appears to be running perfectly fine.
I have an Aeotec Gen 5 Zwave stick and it has all been working and running zwave entities fine a month ago. I ended up doing a complete reinstall for some reasons which don’t really matter and now I can’t (starting from scrath) add my zwave stick. I’ve even done a complete reset of the stick and I still can’t figure out how to add it. I have a feeling something is wrong with the USB path, but even that seems to be too difficult for me to figure out. Can someone please help?

I am eager to learn and I’m truly hoping I can gain some traction with the help of this awesome community. If this question is worded incorrectly or tagged/placed in the wrong location, I apologize. And if I am forgetting any important info please let me know and I’ll add it. Thanks!

p.s. when I look at other similar topics I do not find any recent discussions on using hassbian with a rpi3B+ and adding an aeotec zwave stick.

0 Likes

#2

I am definitely not the xpert of Z-Wave, but what makes you suspect the USB port?

It would help to know your configuration? Are you running a Raspian system, Hassos on resin, Docker on a PC?

0 Likes

#3

One of those options has always worked for me.

This is how I prefered to do it on hassbian as you didn’t have to work about the path changing and it was simpler than making the path static.

2 Likes

#4

I’ll try this as soon as possible and report back how it works. Thank you so much for the tip!

0 Likes

#5

So far this is the most progress I’ve made in months. I’m finally able to see my Aeotec Z-Wave stick added as a node! Now to start trying to add other zwave devices. Thank you so much man!

0 Likes

#6

Well @stevemann, I am still having issues so if you think you have an idea- I would love some input. To answer your previous question I am running hassbian installed image from this link: https://github.com/home-assistant/pi-gen/releases/tag/v.1.5.0 and I have a new Rpi3B+. Does that describe my configuration well enough? Current issue now is that I can’t add nodes. I have done this before and I have troubleshooted what I can. I never did remove nodes last time before I wiped my SD card clean to start over, could that be the issue?

0 Likes

#7

@silvrr I seem to be having issues adding nodes, which is new for me because In my short experience I never had issues of adding nodes before. Any guidance beyond what is already on the documentation?

0 Likes

#8

Use the UI to add a node and get the device as close as possible to your zwave stick.

0 Likes

#9

Repeat- I am not an expert.
That link may tell more experienced people what your Home Assistant configuration. Mine is simply the image file from here: https://www.home-assistant.io/hassio/installation/

I keep copious notes when I install anything, but installing Z-Wave was so simple that I didn’t even make notes. I just put the Z-Wave component in my configuration.yaml file then used the Home Assistant Z-Wave configuration page.

# Enable Z-Wave devices  
zwave:
  usb_path: /dev/ttyACM0

As Silvrr said, the new nodes have to be pretty close- within one hop. I just wired the switches to an extension cord that I cut the plug off. This way, I could put the switch 5 ft from the Z-Stick for it to be initially found. That probably wasn’t necessary since I installed a Shelly switch downstairs (my Z-stick is upstairs) and Home Assistant found it two hops away.

Do you get errors? How are you adding nodes?

0 Likes

#10

Beginners mistake, I did not reset my previous devices. Thank you all so much for the help! I’m now on to different issues I’ll look into in other threads. Thank you all again!

0 Likes