Hassbian DNS and 500 Internal Server Error

Hello guys!
I think I have tried every solution given here in forum to fix my problem but none of them was entirely the same as i have.
So I can connect to my pi with puTTy but when I try to connect to http://hassbian.local:8123/ it gives “hassbian.local’s server DNS address could not be found.” “ERR_NAME_NOT_RESOLVED” and with pi_ip:8123 “500 Internal Server Error Server got itself in trouble”

I have forwarded the 8123 port on my router.
Router I have is ZyXEL VMG3925-B10B
Pi is connected through ethernet.

If anyone has any idea of how to fix this I would be grateful.

Use your actual IP address. Don’t use hassbian.local. Assign a fixed IP address for your PI and be done with it, easy to remember.

If you on you own internal network you should not need to port forward. This means you have a port open to the world, be sure you understand what this means.

If you are trying to access form a device outside your network (ie your phone on LTE service not wifi) hassbian.local will not work, it can only work on your local network.

When I try to connect it with ip address my router gives to it and I have made it static on router (, it gives the “500 Internal Server Error”.
So do you mean I still need to assing the ip for it somewhere on its files?
I can access raspberry with its ip address through puTTy.

Were you ever able to connect to HASS via the web browser previously?

Did you check to log to see if HASS is even started?


Ah thank you, I have done the update progress many times before but now it started working when i just followed the upgrade steps from your link.
It works now by the ip address.

Thank you for your help!