Hassbian Install not loading homeassistant

I have read through the instructions, and several of the forum posts about installation and doing everything I could I still can not get homeassistant.service to start and run correctly. If I do --force it fails to load. I also am unable to connect remotely. I can see it on my router (every other time I refresh my router), and rfkill shows both on. I have reflashed the drive twice and still nothing. Any ideas? I am running a RPi 3b+ v1.2 with a smarti case and 7" touchscreen. powersupply is what came from canakit, with a spliter to also power the screen. I have a usb set up with configfiles, but have also run sudo raspi-config and set up country and wifi info. The first load I changed the password, on the others I did not.

What do your logs say?

Systemctl status home-assistant should show something

Dmesg, journalctl -xe, etc etc

unit homeassistant.service could not be found

So from the documentation, did you perform the steps to verify the service was installed?

If you find that the web page is not reachable after 30 minutes or so, check that you have files in /home/homeassistant/.homeassistant/ , if there are no files in this location then run the installer manually using this command: sudo systemctl start install_homeassistant.service .

yes, multiple times. and as I stated above I tried the --force method, it runs but has multiple errors ( enough I couldn’t read them all on the 7 inch screen).

If you find that the web page is not reachable after 30 minutes or so, check that you have files in /home/homeassistant/.homeassistant/ , if there are no files in this location then run the installer manually using this command: sudo systemctl start install_homeassistant.service

So, do you have files in /home/homeassistant/.homeassistant?

Yesterday i have the same problem

I write this and then work for me.

$ sudo hassbian-config upgrade homeassistant

Sorry I haven’t updated in a while, I have been busy with other home projects. I finally got home assistant to load and even got the generic pixel GUI to load, but I have yet to get the actual home assistant screen to open (doesn’t even have an option or icon for it) a big part of why I went with hassbian over hass.io is because I am not running a headless unit. All I have access to is file manager and terminal. I was hoping once home assistant loaded it would already have the GUI, but I should have known that would be too easy LOL.

Open a browser.

Load the URL.

There you go. There is no application that’s going to be on your desktop.

I have tried the link, it never works. As I said in my post, I don’t even have a browser on the RPi. Since every time I have posted it is like flamingm0e doesn’t read half the post, let me start over again. I have a RPi 3B+, with a 7 inch touchscreen case and camera (camera isnt very visable in picture) I am trying to use this as a DIY google home hub (the one with the screen and camera). I got the net issue fixed and was finally able to get homeassistant.service to download and install. but now that is loaded I want to be able to run it as headed unit with lovelace UI in it like a google home hub, but that isn’t installing, and I don’t know how to make it or even run home assistant in a VM, I’m a noob and don’t know the lingo so I am trying to figure out what everyone is saying, but don’t get half and the other half seems like nobody reads where it answers that questions. I apologize for my frustration come across the way it does, and I know alot of it is probably simple misunderstanding, but this thing is almost becoming more pain than it is worth.

I’ve read it. I fully understand what you’re trying to do.

Ok? Why would you need a VM?

Install one then? I don’t really understand why you’re making this so complicated.

Install a browser. Open said browser. Load the URL for your HA. Done.

need the VM because home assistant runs in a vm (according to the documentation it talks about it several times)

I’m not trying to make it complicated, I just want it to run the way it is supposed to. There is supposed to be a way to do it, I just don’t know how to do it. This is the set up I am trying to run, might be easier to run it another way but this is what I am looking for, I want it as a stand alone system run on and through the RPi. Maybe home assistant isn’t the option I am looking for.

So do as @flamingm0e says. Install a browser. Profit. In hassbian home assistant does not run in a virtual machine, it runs in a virtual environment.

No it doesn’t. Hassbian runs home assistant in a PYTHON VIRTUAL ENVIRONMENT which isn’t a VM.