Hassbian root password not working


#1

My hassbian root login (basically username: pi and password: raspberry) is not working. I am still in 0.71v. Anyone having this issue. I didnt change the password.


#2

The root account doesn’t have a password set in a default hassbian installation. If you mean the pi user account, you can change the password using raspi-config.

SSH into your raspberry pi and run:

sudo raspi-config

at the prompt.


#3

Sorry i meant the pi user. How do i login since the default password is not working.


#4

any help please?


#5

Password: raspberry
When you type the password this will not show on screen just press enter.


#6

@sramnarayan did you ever get to the bottom of this? I’m experiencing similar issues.


#7

No I reinstalled the whole thing.


#8

In case anyone is still struggling with this.
When you run sudo hassbian-config install manager from the shell it starts by asking you to set up a user account (inside the install script).
Whatever you input there as username/password will be used in the web interface of the manager.
Hope this helps someone.


#9

I’m curious, do you find manager useful?


#10

Yes, it seems to be a rather solid install script. Nice touch with the autocomplete for options as well!
Though I had some issues on the initial install (which was from this Hassbian image):
https://github.com/home-assistant/pi-gen/releases/tag/v.1.5.0
It’s possible that I messed something up as I set up a headless install (wpa_supplicant for wifi + ssh) and went to bed. But the install was not complete when I got back and there were some file permission issues. Not 100% sure if there was a power cut or something mid install, as I did not think to check log files.
For some reason I decided to try and salvage the install and eventually managed to get manager installed and this got me at least halfway operational.
Nice tool. Normally I might have gone for the config files straight away but this was handy.
Thanks for all the work!

/h