Hassbian Samba share issues with Windows 10

Just got a new laptop with Windows 10 pro and I can’t get the home assistant Samba share to connect. I’m running Hassbian on a RPI3. Works fine on my Windows 7 computers.

windows gives me Error code: 0x80004005

I’ve googled around and have tried several things but the issue persists. I have to imagine others have had trouble with this and have a solution.

Go to Control Panel->Programs, select Turn Windows features on or off, then search for SMB 1.0/CIFS File Sharing Support and enable it.

I’m not a Windows user, but ran into a similar problem on Xubuntu 18.10.


I’m no expert by any means but I ran into a similar issue trying to get my network shares set up for running Kodi on a Debian box.

In my searches I found that I had to use the same version of smb as the windows machine was using. In my case it was vers=2.

I also saw someone post that smb version 1 was disabled due the wannacry virus using that exploit to get into peoples machines.

Again, I’m no expert so that could all be hogwash. But I just wanted to throw that out there.

It’s probably best to just find out which version of smb you’re windows machine is using and set that up in Linux.

I used bruh’s instruction on setting up samba, but I couldn’t access the share after Ubuntu 17.10. I run development versions, so being able to access the samba share on my Hassbian setup is important. I had to add the following line to the global section of /etc/samba/smb.conf on the client to gain clickable access.

client max protocol = NT1

This was the first thing that I came across and tried - this did not resolve the issue for me.

I’ve tried enabling SMB 1.0/CIFS File Sharing Support in Windows Control Panel (I don’t think this is a preferred solution anyways for security reasons) - It did not work.

I’ve tried setting client min/max protocol = SMB2 and SMB3

I’ve tried turning off guest mode

I’ll try setting max protocol to NT1 that’s the first time seeing this option.

NT1 option didn’t seem to make a difference.

I also updated samba hoping to pull down the latest version which I would assume supports SMB3. However, it said I already had the latest version.

I recently came back to this as I’m switching over to HASS.io. I was able to resolve it:

You need to enable SMB 1.0/CIFS file sharing in the control panel, but you also have to disable guest mode AND provide username/password credentials. By default the samba add on in HASS.io has guest mode set to true.