Hassbian Service and Automations running, but web GUI "cannot connect to server" locally or remote

I’m running Hassbian 0.73.1 on my Raspberry Pi 3 B (USB booted). It’s been running fine for the last week or so, and then suddenly a couple of days ago the web GUI started refusing to connect at port 8123. Status check says the homeassistant.service is running, but GUI won’t connect.

I’m pretty new to Linux (though I’ve gotten quite the crash course setting up my Pi!); googled extensively and haven’t found an answer to this yet.


  1. I’ve tested on Chrome, Edge, Firefox, Safari Mobile, and Home Assistant app (and wiped cache); no luck on any.
  2. I’ve set up a DuckDNS URL and port forwarding for remote access which worked fine, but the GUI “cannot connect” through the DuckDNS URL at port 8123 (whether connected to home network or not) or by entering the IP Address of the PI (when connected to the home network). Configurator at port 3218 runs on both.
  3. The homeassistant.log generally appears to be normal (from my understanding). Only errors thrown are basic component errors (shouldn’t affect, I wouldn’t think) and a “KeyError: programid”, which doesn’t seem to be related from Googling
  4. I’ve restarted my router, Home Assistant, and my Pi multiple times; no luck.
  5. Ran # netstat --listen to check for listening ports, and it shows 8123 as actively listening. Other ports listed are definitely working.
  6. As noted in the title, my Automations still ran this morning, so apparently at least some piece of HA is still working. Just not the GUI.

I’m at a total loss on what to do from here. Help!

Update: it works now, and I’m really not sure what I did different.

For about the 5th time, I ran the upgrader, restarted Home Assistant, and checked my router configs and then the GUI just showed up. So I don’t know what to say other than keep doing that and make sure everything is in order, and it’ll work itself out, apparently.