HassIO 0.84.5 - Zigbee Devices Dont Show Temperature

Tags: #<Tag:0x00007f7396897f18>

Have got Nortek HUSBZB-1 to control Zigbee and Zwave devices directly from HA. It is configured correctly and been able to pair Zigbee devices.

However I have tried adding two zigbee devices with temperature sensing capabilities and both are not showing the temperature.

  1. Device is a Visonic MCT340E Contact Sensor with Temperatute. The contact sensing is working ok, however the temperature always shows as unknown. All details and screenshots mentioned in this thread post
  1. Device is a Bosch ISW-ZPR1-WP13 with temperature, it gets paired correctly and probably motion sensing is working, however temperature reading from this device also shows as unknown. Adding screenshots here.

While adding (removing and readding to check) both devices similar messages are thrown out in the logs

2018-12-27 21:27:32 ERROR (MainThread) [homeassistant.core] Error doing job: Task exception was never retrieved
Traceback (most recent call last):
  File "/usr/local/lib/python3.6/site-packages/homeassistant/helpers/entity_platform.py", line 344, in _async_add_entity
    raise HomeAssistantError(msg)
homeassistant.exceptions.HomeAssistantError: Entity id already exists: zha.zha_bosch_iswzpr1wp13_b44d225c. Platform zha does not generate unique IDs
2018-12-27 21:27:34 ERROR (MainThread) [homeassistant.core] Error doing job: Task exception was never retrieved
Traceback (most recent call last):
  File "/usr/local/lib/python3.6/site-packages/homeassistant/helpers/entity_platform.py", line 344, in _async_add_entity
    raise HomeAssistantError(msg)
homeassistant.exceptions.HomeAssistantError: Entity id already exists: binary_sensor.bosch_iswzpr1wp13_b44d225c_5_1280. Platform zha does not generate unique IDs
2018-12-27 21:27:34 ERROR (MainThread) [homeassistant.core] Error doing job: Task exception was never retrieved
Traceback (most recent call last):
  File "/usr/local/lib/python3.6/site-packages/homeassistant/helpers/entity_platform.py", line 344, in _async_add_entity
    raise HomeAssistantError(msg)
homeassistant.exceptions.HomeAssistantError: Entity id already exists: sensor.bosch_iswzpr1wp13_b44d225c_5_1026. Platform zha does not generate unique IDs

Clipboard%20Image%20(5) Clipboard%20Image%20(6)

Clipboard%20Image%20(9) Clipboard%20Image%20(10)

I am a non-techie beginner with Hassio and home automation in general, so trying to learn the ropes.

Based on the above behavior I believe the problem lies either with Nortek HUSBZB-1 USB Stick or the way HA implements and talks to Zigbee devices.

Can anyone with greater technical insight reproduce a similar setup and try to guide as what needs to be done over here.

Would appreciate all the help and guidance.

Thanks.

1 Like

I can’t help you with your current problem but I have had some of the Bosch motion sensors for about a year now and when I first tried to integrate them into HA they would pair but then drop off the network in around 15 minutes and I never could get the motion sensor to work.

I posted several threads about this at the time trying to get them to pair with my HUSZBZ-1 stick and many others had the exact same issue that I did.

After several months of asking about it on the forum I just gave up and resigned myself to the fact that they would never be supported.

Then Zigbee2MQTT came along and then I had hope that it would work I am literally just now working on finally getting them integrated into HA using that component.

Then lo and behold I see that you already have them connected to HA using just the HUSZBZ-1 stick!

So my question is how did you manage to get them to pair and reliably stay paired with the zigbee controller?

Are they now supported out of the box by the zha component?

1 Like

Well I was able to pair them without any special steps. I put the sensor in pairing mode (which it is if it is opened brand new and inserted with batteries). Then you can use the call service Zha.permit. Press the call service button (while sensor in pairing mode), and after a while -5-10 sec, you can go to overview or dashboard to see it will appear as Motion and Temperature sensor.

Clipboard%20Image%20(11)

The problem is, with this and the other MCT 340E, the temperature reading is not working.

Share with us here if you were able to make them work with HUSBZB-1 with working and responding temperature.

Also please update how did you make it work with Zigbee2MQTT (since it understand it does not work with HUSBZB-1)

Thanks.

Hello again

Did you ever verify that the motion detector actually detects motion (state changes from ‘off’ to ‘on’)?

I paired my motion detector to HA and I get an initial state for both motion and temperature but neither of them ever update.

I’m pretty sure the device is sending an initial state that isn’t some sort of default because I paired the same device twice (after removing it from HA and doing a reset on the device) and temperatures that it sent to HA were different both times. the first time the temp was 77 then the next time it was 81.5.

I was just wondering if yours was really sending a status change when motion is detected or if this is a lost cause until I can get it supported by zigbee2mqtt.

In my case the

  1. Visonic MCT340E Contact Sensor was correctly updating contact state as a binary sensor. Temperature sensor never worked.

  2. Bosch ISW-ZPR1-WP13 (you are right) was paired in an initial (open/close as opposed to motion/no motion) state and then wasn’t changing the state after it, no matter how much motion happens in front of it. Temperature sensor in it never worked as well.

To my experience, getting a HUSBZB-1 to pair devices was a failed/flop idea and never really worked the way i envisioned it to be.

Ultimately i paired these two devices with my recently upgraded SmartThings hub (V1 and V2 on the way) and I was immediately able to see the status updated and temperature from both sensors. Would use the smartthings2mqtt bridge to stream this data to HA to be able show in dashboard and for possible automatons.

Thanks.

Ok, thanks for the information.

When you said you got the Bosch to pair successfully you got my hopes up :smiley: only to now dash them again because it’s still not woking :sob:.

Oh well, it looks like zigbee2mqtt is my only last best hope to get these working.

And just so you know that the zha/HUSZBZ-1 combo on HA usually works fine, I have paired several zigbee LED bulbs with the stick over a year and a half ago and they work good. So it’s not a completely losing situation. I think these sensors are just special cases that aren’t supported in zha.

Best of luck keep us posted here about the final procedure you are able to devise to make it work with zigbee2Mqtt, as I mentioned on zigbee2Mqtt page it is mentioned to have the following parameter set

serial_port string yes Serial port for your CC2531 stick

so I assume it meant to work with some specific USB zigbee stick and not Nortek HUSBZB-1, which I tried anyways, without sucecss.

Sure I would take your word for HUSBZB-1 being a viable option, however my experience until now was almost 40USD down the drain, time to write off the sunk investment with the dawn of the new year :smile:

Note. The ticket I opens still there. Feel free to communicate w/ dev on this issue

https://github.com/home-assistant/home-assistant/issues/16632

I sort already gave up on Visonic sync up with HA using Nortek HUSBZB-1. Maybe the available time I can dedicate to deep dive troubleshooting the issues, is something I cannot spare now.

I reverted to pair my sensors with SmartThings hub (got the ZIgbee radio activated by SmartThings as it was deactivated in older models) . As i have the smartthings integrated with HA using SmartThings bridge and MQTT , I can now see the sensors state in HA dashboard.

Thanks.

I just upgraded to 0.85.0, and the sensor showing unknown again…

I did some debugging in my case.

I remove the 2 sensor, re-add them. It works again.

What I noticed is the sensor new name has changed somehow.

Using the new ZHA config panel in 0.86.0+ and hitting “reconfigure node” while the sensor was awake fixed the problem for me!

Resurrecting this from a long time ago. I’m trying to get my Visonic MCT-340E sensors working with my HUSBZB-1 and everything works flawlessly except for the temperature. It just says “Unknown”. I’ve tried removing the battery, pressing the tamper switch, moving the sensor closer to the HUSBZB-1, and nothing has worked. Did anyone ever find a definitive solution to this?

@mike1237 what do you mean by “while the sensor was awake”?