Hassio: add-on not start at boot

Hi. I installed Hassio. I made a minimal configuration. I configured these add-ons: Samba, Duck DNS, SSH server and Check Home Assistant configuration. It is work. But although I have set the start up to load the system some of them (random) don’t start. Has anyone already had the problem?

1 Like

Hi @oldmaker, I found your thread by searching. I’m sorry nobody answered you because I have the same problem.

Everything has been working find for about a year. I’m running the latest version of hassio on a Raspberry Pi 3B+. The problem appeared randomly about 2 weeks back, and prompted me to upgrade from version 101.2 to 102.3, but the problem remains.

Basically, after my system boots, none of the plugins that are set to Start on Boot will actually start on boot. I can manually start all of them, and they will all function correctly, but it means that every time I lose power (which is a thing in the 3rd world), I cannot expect my system to just come back up. I have to manually start all services. Which means I have to be hypervigilant about whether the power dipped, even for a second, because now nothing in my house works. It’s getting old fast.

Can anyone offer any advice as to why my plugins suddenly won’t start on boot anymore? Is anyone else experiencing this?

1 Like

Updating because I solved this, in a roundabout way.

If you are experiencing plugins that do not start on boot, even though they are set to start on boot, here’s how to fix it.

Go to any plugin that is not currently running, or stop one that is. Disable Start on boot. Start the plugin. Then enable Start on boot.

Now go through the rest of your plugins that should start on boot, and notice that Start on boot is suddenly disabled on all of them. Enable it, one by one.

All better.

That’s a weird one. No idea why this happens, or why that fixed it.


I hope this fixes it for me