Hassio behind CG-NAT

I know this question was already made in the Forum, but I think that was not really answered.

My Hassio installed into a Raspberry pie 4 is behind an Asus 4g… The internet provide from a phone operator.

The problem is that this phone operator give me a private ip (behind the NAT of the opertor)

Someone has a free solution for that or using nabu casa is the only solution?

Just for info: My asus is connected to NordVPN with the VPN client

Other webhookrelay options cost the same as nabu casa and don’t go towards supporting home assistant development.

There’s also this option:

The lowest cost is again equivalent to nabu casa, does not support home assistant but is your own server.

1 Like

Just a final question… Could I have problems using that with google assistant or alexa?

I don’t use either of them. Someone else will have to let you know.

Sorry, but I’m new here…Do you think that I need to create another topic for that?

No if someone knows the answer they’ll read this.

It’s possible to use google assistant only in Local Lan? As I said, i have a private IP, and I don’t Control the Nat.
It’s possible to configure google assistant and hassio, and using them only in my local network?
If yes someone could help with that?

Hi everyone, I solved this problem by having a pivot VM in AWS, a reverse tunnel and a couple of reverse proxies. All the details here: Expose Home Assistant on CG-NAT networks – TheGabo.dev