Hassio caddy

I am having trouble accessing my system remotely. I have forwarded ports 80 and 443, everything works great locally, but I cannot access remotely, I get a time out. See settings below.
Caddy file
xxxxx.duckdns.org {
header / {
Strict-Transport-Security “max-age=31536000; includeSubdomains”
X-XSS-Protection “1; mode=block”
X-Content-Type-Options “nosniff”
X-Frame-Options “SAMEORIGIN”
Referrer-Policy “same-origin”
proxy / {

config.xxxxx.duckdns.org {
proxy / {
Configuration file
title: Configurator
icon: mdi:wrench
url: https://config.xxxx.duckdks.org:443

mistype in last line could be the cause.

Thank you for your quick response. I have fixed my typing error which allows configurator to work internally, but I still have no external access. I have tested that port 80 and 443 is open. Any other suggestions?

This is working for me:

home.xxxxx.nl {
    timeouts none
    proxy / {


  api_password: yourpassword
  base_url: home.xxxxx.nl

that’s it.

are you certain your domain is registered? Is it pointing to the right IP address? Is your ssl certificate working? I am using an identical caddy file…

Also 443-443 and 80-80 right?

Thank you so much for your reply. I am using duckdns. When I do a tracert on my domain, it goes to my home external IP. Does that mean my domain is registered? How would I know if the ssl is working. I have tried to stop lets encrypt with duckdns by removing the duckdns addin as I believe Caddy is doing the ssl.
Yes I am forwarding both ports to Really appreciatate your assistance, as this one is wearing me down.

Mark… the IP address in your caddy file is not
I actually just use localhost in my docker file - is your Pi If it is you need to change the caddyfile and restart the addon.

Yes you need to disable LetsEncrypt in the DuckDNS addon.

also make sure your ISP isn’t blocking ports - mine was (Aussie Broadband) and I had to get them to unblock.

David, I think you have solved my problem. My Pi address is I will change my caddy file to localhost. I don’t think the ports are blocked as I have check with some websites that test for open ports.
You are a legend. I can’t wait to test tonight when I get home.

Thank you for all your great support. Caddy is now working. Localhost was the issue.
Does anybody know how to allow Mosquito ports 1883 through Caddy?

Afaik caddy is a http proxy and mqtt doesn’t make use of that.

Thank you. I had the idea that external traffic went through caddy. OK then I must have something else wrong, as I was able to connect between owntracks and Mosquito before installing caddy.