HAssIO can't boot via USB3 (RPI4)

Gents, is there any way to solve following mystery: RaspberryPi 4B, updated firmware + SSD (PNY 120GB) + SATA/USB3 converter.

  • with ordinary Raspbian on board and SSD connected to USB3 everything works well,
  • with Hassio (hassos_rpi4-64-5.13.img.xz) it works only when SSD is connected into USB2 port. USB3 - can’t boot (I see starting screen for less than second, then screen is black, Act LED on RPI is not blinking).

For test I tried to use pendrive USB3 instead of my SSD, but result was the same. Nevertheless, as I wrote, raspbian is working fine, so I believe, it has to be software problem or at least it should be possible to fix it by software. I found here some discussions about similar problem, so it looks it is known issue, but is there a solution?

Are you powering the ssd via the pi or a separate power supply?
I’ve been running a 8 gig pi 4 booting from a ssd with 0 issues for several months. The ssd is powered separately and is connected to a USB 3 port.

some usb3 adapters are not compatible with rpi

The rpi usb port do not supply alot of power, so the power has to come from an external power supply connected to the ssd adapter. Some power supplies are gimmicks or dont supply the proper power

I bought this one first… It did not work

I then bought this one… and it works great

Ok, thx for info. At now I found other adapter, which started to work fine and enjoying resolving the problem i started to configure, restore backups etc. Unfortunately after several changes, reboots, my HA crashed and according to console (during boot up) it looks that it lost part of filesystem. So definitely this new, “good” adapter isn’t so good also.
Additional question: if currently I run and configure it via USB2, after changing adapter (e.g. for this recommended) and reconnecting to USB3 it just start to work, or new complete installation will be needed? Other USB -> other mounting point, so I afraid it won’t be easy way, but better to ask, maybe there is any method to simple change it? :slight_smile:

Hi @Jarek_P, I’m experiencing the exact same problem.

Raspberry OS and Debian boot flawlessly from USB3 ports, HassOS only starts from USB2 ports on RPi4.
So the issue is in my perception related to HassOS and not to an unsupported RPi4/USB/SSD/… combination.

Using latest HassOS and RPi firmware, Kingston M2 SSD in an Icy Box enclosure.

Interesting. After this my experience and after some readings I was sure that issue is connected to not enough power given by RPi USB port for SSD, you know: USB3 means higher speed and causes a bit higher power consumption and it makes a difference. With your observation it seems to be more complicated, but who knows, maybe we are playing direct on the border and here any differences in data transfer (between startup of pure debian/raspbian and bigger and much more complicated hassio) matter?
My system is working fine from that time (still via USB2) and I’m absolutely not going to destroy it by checking such ideas, but it would be interesting to check USB3 scenario but with external power supply for SSD.