Hassio configurator

Complete beginner here that has been googling and foruming for hours.

I was doing the HA install and got as far as adding the HASS Configurator (not very far). I pasted the first few lines of code in the yaml.config (that HA setup told to try as a test) and now I am unable to go into any of the add-ons.

The only options on my sidebar are overview and configurator now and clicking on overview shows nothing…
In the home assistant log it says there is an incomplete core configuration? It can’t detect latitude, longitude, time zone, etc.

Sounds like you have syntax errors in your YAML configuration file. Have you tried deleting the stuff you added so the configuration.yaml is exactly like it was when you first setup HA?

Double check your indents in your configuration.yaml file. No tabs, each indent is specifically 2 spaces.
I highly recommend you also do a configuration check before restarting. Ya never know when you’re going to fat finger something.

Yes I have tried deleting. Also, I did check the indents and changed them to 2 spaces, with no indents.

My yaml.config now reads: ` panel_iframe:
title: Configurator
icon: mdi:wrench
url: http://hassio.local:3218

My Log now says: `2018-10-05 00:23:37 WARNING (MainThread) [homeassistant.config] Incomplete core configuration. Auto detected latitude: None, longitude: None, name: None, time_zone: None
2018-10-05 00:52:38 ERROR (SyncWorker_2) [homeassistant.loader] Unable to find component url
2018-10-05 00:52:38 ERROR (SyncWorker_2) [homeassistant.loader] Unable to find component title
2018-10-05 00:52:38 ERROR (SyncWorker_2) [homeassistant.loader] Unable to find component icon
2018-10-05 00:52:38 ERROR (MainThread) [homeassistant.components] Component not found: url
Component not found: title
Component not found: icon

I’m really sorry if i have committed a basic error. Like I said, I have tried figuring this out for a while now…``

you replaced all the config information with only the iFrame. You needed to ADD the iFrame, not replace everything else with it.

Try this:

  # Name of the location where Home Assistant is running
  name: Home
  # Location required to calculate the time the sun rises and sets
  # Impacts weather/sunrise data (altitude above sea level in meters)
  # metric for Metric, imperial for Imperial
  unit_system: metric
  # Pick yours from here: http://en.wikipedia.org/wiki/List_of_tz_database_time_zones
  # Customization file
  customize: !include customize.yaml

# Python
# python_script:

# Map

# Show links to resources in log and frontend
# introduction:

# Enables the frontend
  javascript_version: latest

# Enables configuration UI

  # Uncomment this to add a password (recommended!)
  # api_password: !secret http_password
  # ssl_certificate: /ssl/fullchain.pem
  # ssl_key: /ssl/privkey.pem
  # trusted_networks:
  #   - !secret trusted_network
  ip_ban_enabled: True
  login_attempts_threshold: 5
  # Uncomment this if you are using SSL/TLS, running in Docker container, etc.
  # base_url: https://my-duck-dns-domain.duckdns.org:8123

    title: Configurator
    icon: mdi:wrench
    url: http://hassio.local:3218

# Recorder

# Checks for available updates
# Note: This component will send some information about your system to
# the developers to assist with development of Home Assistant.
# For more information, please see:
# https://home-assistant.io/blog/2016/10/25/explaining-the-updater/
  # Optional, allows Home Assistant developers to focus on popular components.
  # include_used_components: true

# Discover some devices automatically

# Allows you to issue voice commands from the frontend in enabled browsers

# Enables support for tracking state changes over time

# View all events in a logbook

# Sensors

scene: !include scene.yaml
group: !include groups.yaml
automation: !include automations.yaml
script: !include scripts.yaml

Enter YOUR latitude, longitude and timezone at the top.

This is as close to the default config yaml file as I can get.

Ok. That definitely makes sense and I changed it to what you recommended and I’m still having difficulty. Is there a way to completely restart this process?

I tried taking the memory card out of the pi to re-flash HA, but it will no longer recognize the card…

if you want to reflash, you will need to delete the partitions on the card first. If you use Etcher that might do that for you or else you can use MiniToolPartitionWizard (free) to delete all the partitions and make one large one again and then reflash.

Went through a long and convoluted process, but I got everything reformatted and went with hassbian and putty instead. Much easier, thanks for the pointers!