Hassio died after update to 0.90

yesterday I launched the update from 0.88.2 to 0.90.1 on a PI3+
I didn’t comment the api directive in config (I admit, mea culpa).
Now I can’t access the UI, tried to access with samba but doesn’t connect. Tried to telnet or ssh with Putty but doesn’t answer.
I tried to read the SD but from windows I can see the boot only.
Please give me a tip to recover my Hassio. I spent a lot of time configuring it.



Re-flash the SD card with home assistant as per the getting started documents.

Set up SSH or SAMBA addons.

Copy across the snapshot that you previously made and moved off the SD card. You do this regularly dont you?

Refresh the snapshot page.

Restore the snapshot.

Yes, I hope it is complete. But if I restore the current config the config file will have again the same issue and block again the system.
Is it there any way to access the SD and modify the config file?



Yes. You can open the snapshot file with winrar or 7zip or some other compressed archive software. There’s another compressed archive inside this called homeassistant that contains your config directory.

I had the same thing happen to me this weekend. I am running windows 7 on my pc and reading the sd card didn’t show anything relevant. I downloaded Ubuntu linux and burned to a DVD. I ran the DVD in Live Mode and was able to pull my backup file as well as my automation, config, and other files from the sd card. Hope this helps.

Fantastic. I’ll do the same.
Anyway I’ll install a new Hassio on a different SD and try the recovery.

Thanks all

I hope this help