Hassio died, how to do a post-mortem?

I made some changes to config, checked they were OK, then restarted the server. Result is no response from Hassio, and black screen when I plug the pi into a monitor. I have the SD card but cannot see a way to view the logs. How to proceed with a post-mortem and resurrect the instance?

Do you have samba installed? If so you can check the log, edit the config file that is causing the issue and do an hard power reset to reboot the Pi.

Above is how i solved it when i messed up again :wink:

Try this https://home-assistant.io/developers/hassio/debugging/

You will be able to login and when you do a “docker logs homeassistant” you will probably see an error message
Fix the config (located in /resin-data/homeassistant or via the samba add-on) and restart with “docker restart homeassistant”

I ran into the same issues as you–validated the config through the UI, then restarted Home Assistant but the UI wouldn’t load. Here are the steps I recommend checking to get your HA back up and runnning.

  1. If you have the Samba Share add-on installed, then you may be able to access your \config folder, even if the UI is not responding. Open the home-assistant.log and check for errors. If you spot one, update your .yaml files and go to step 2
  2. If you have SSH add-on installed, you may be able SSH and reboot from there. Follow the steps here if you’ve never done it before. Once logged in, type the command ‘hassio host reboot’ to do a proper reboot.
  3. Depending on how many components you installed, reboot times range from a minute to a few minutes. Try logging into the HA UI after a few minutes.
  4. If your Samba share and SSH isn’t working, then…unplug/replug your Raspberry Pi from power and hope for the best!

Some things to be aware of:

  • The Validate Config button under Configuration sidebar is not 100% reliable. I can think of five occasions where it reported ‘valid config’, but the HA logs show a failure to load the config. Continue using it, but follow my steps above if your HA UI isn’t accessible.
  • Do not use the ‘Restart’ button under Sidebar >> Configuration >> Server Management. It just doesn’t work, and you will have to unplug and replug your Raspberry Pi twice to get the UI loading. To reboot properly, go to Sidebar >> Hass.io >> 3 vertical buttons >> Restart Home Assistant or login via SSH and use command ‘hassio host reboot’
1 Like