Hassio doesn't connect to network anymore

Hello, maybe somebody of you can help me with this. From one day to the other my hassio doesn’t connect to my network anymore. What is my system:
Raspberry Pi 4 4GB
OS: Home Assistant OS 5.13 rpi4-64

The system was working perfectly fine before. The Raspberry is connected via cable.

What has been done so far:
I connected the Raspberry to a screen and keyboard. When I type in “ip addr” I can’t find the eth0 interface. Also when I use “ha network info” I don’t see it. I tried enabling it via “ha network update eth0 -e”, but it tells me “Interface eth0 does not exist”. This seems weird to me, but I don’t know how that was before.

Also interesting to note is, that when I first looked for my running docker containers with “docker stats” I realized that the homeassistant container was not running. I restartet it with “docker restart homeassistant” and now it is running.

Regarding the logs: The homeassistant container gives me the following warnings and errors:
Timout on /supervisor/options request
Cannot connect to InfluxDB due to 'HTTPConnectionPool(host=‘localhost’, port=8086): Max retries exceeded …
A los of connection errors and warnings for the addons
The supervisor container gives a few connection warnings and errors for whoami.home-assistant.io:443 and hassio_audio.

I tried to connect to my WIFI with the “ha network update wlan0 --wifi-auth wpa-psk --wifi-mode infrastructure --wifi-ssid XXX --wifi-psk ZZZ”. It tells me “Command completed successfully” and when I list “ha network info” it tells me under interfaces that is is connected to the wifi but it doesn’t have an internet connection. My router doesn’t list the device as connected however, so it seems like this ain’t working for me.

A few sidenotes: I use a pretty new SanDisk A2 SD card, so I would be suprised if that one is broken (already). I have recent snapshots saved externally. The small LEDs (green and orange) of the Raspberry below the ethernet port are glowing when the ethernet cable is connected. I also tried to insert a SD card with Raspberry OS on it and then the connection works flawless, so I don’t think it is a broken Raspberry.

It is likely that eth0 is not used as the name of the Ethernet interface.
If you are at the ha > cli prompt, type login and you should get the linux root shell prompt.
Type nmcli device show and see what the output shows.

1 Like

When I list my interfaces using ‘nmcli device show’ I see the following interfaces:
wlan0 wifi
docker0 bridge
hassio bridge
dummy0 dummy
several vethXXX ethernet
lo loopback

I doesn’t show me a physical ethernet interface. Right now the wlan0 wifi interface is marked in green and it is stated that it is connected (even though it doesn’t have an internet connection, nor can I see the Raspberry in my router interface)

Might this be related to the hassio_multicast container? I can see that it is started every few minutes. The log file of the multicast container says “mdns-repeater (3): error: at least 2 interfaces must be specified”

In the beginning of the log file it states " specifies an interface like “eth0"”. Not sure what that container does but might it be related to my issue?

Its very unusual that the physical device does not show up.
One more suggestion would be to go back to the linux prompt and type:
ls -l /sys/class/net
I’m not sure about RPi, but in my case (Intel) it should show something similar to the following:
enp0s25 -> ../../devices/pci0000:00/0000:00:19.0/net/enp0s25
OR look around directly in /sys/devices/xxx to see if you can find something similar.

If ethX or enpX is not there, then something is probably broken (not sure if hardware or software ethernet driver). The ETH LED lights are usually driven by hardware, which is a good sign, but there still may be something broken. From your description, it sounds more like a software driver is not seeing the ethernet hardware properly. Possibly hardware conflict? Possibly HassIO problem?

1 Like

The output of ls -l /sys/class/net doesn’t show any physical ethernet interface. It shows the same virtual interfaces as ip addr and the physical wlan0 interface.

Don’t really know what to search for in /sys/devices/ but it seems to me that I have to restore a home assistant snapshot.

Do you know what the container hassio_multicast is doing? The line "specifies an interface like “eth0"” got me thinking that maybe this container has something to do with it?

Thanks a lot for your help so far!

I don’t think a Docker container is the problem. Docker usually creates vethXXX and bridge interfaces and makes use of existing physical interfaces, but it doesn’t create/destroy physical interfaces.

You can try restoring a snapshot, but my guess is that won’t restore the physical Ethernet interface that is missing.

A suggestion would be to upgrade HassOS to the latest (6.1) and see if that will restore your physical Ethernet interface.

1 Like

Oh yeah, I meant reinstalling a fresh HassOS and restoring a snapshot afterwards. Only restoring a snapshot wouldn’t make a difference, I guess.

I will first try to upgrade HassOS manually without an internet connection. Need to see how this can be done though.

Another pretty offtopic question: Do you know how to change the keyboard layout in the HassOS console? I found this post link1 in the forum, where nobody answered, and this link2 issue report on Github. Do I need to copy the binary for my preferred keyboard layout onto the Raspberry and then load it using loadkmap ? Have never done this before, but it is really annoying to use a different keyboard layout haha

As I don’t know how to manually upgrade HassOS without an internet connection and after a brief google search it sounded like it ain’t recommended I completely reinstalled HassOS and restored a snapshot. Now everything is working again. I can also see the expected network interface “eth0” on the host. Very weird and I still don’t know what was causing the issue. Let’s see if it happens again…

Thanks @wmaker for helping me out. Cheers.

Hi there,

Just for future reference, I’m having the Wifi issue. Not the missing eth0, my eth0 is there and it’s fine, but my wifi says it’s connected but doesn’t get an IP.

Guess I’ll go the re-install route for now.

Did you set the ipv4-mode of the wifi interface to auto (instead of off)?

You’re the boss. Worked fine!

Thank you

1 Like

I had the same issue recently, just after updating to 10.1 I think. The only wireless way in was via nabu casa and I rolled back to a previous snapshot and everything became stable. I then updated again and no problems so far. My wlan0 interface disappeared and trying to restart the service through the command line didn’t work. No idea what happened.

ncmli are not in hassos, bash command not found… and many others like sudo etc.

I’ll try to explain… To use the nmcli command, one has to gain access to the linux operating system that hassio uses, and in general, this operating system is called HassOS.

  • One way to gain access to HassOS is to use the “console” port on the device that is running hassio. Here you’ll be in the HA CLI shell. Type login which jump you into a shell in HassOS.
  • Another way is to ssh into hassio over port 22222.

However, if one tries to use for example the “Terminal & SSH” Add-On, this only provides access to a docker container running the HA CLI, but does not provide access to HassOS. So if you try to use nmcli from this Add-On, indeed you’ll get an error message as you described.

1 Like