Hassio doesnt start with last update!

Not booting here neither :frowning:

As an FYI, I am running from an SSD. So SSD Boot works with 5.8.

This is how i got Home Assistant working again on my Odroid C2:

Download 4.15 image and write to storage (SD/eMMC): https://github.com/home-assistant/operating-system/releases/tag/4.15

When credentials are asked, choose the restore from backup option and select your pre-upgrade backup.

After a successful restore run the following command in the terminal:
ha os update --version 4.20
to upgrade HassOS to version 4.20.

HassOS 4.20 is now running stable with Supervisor 2020.12.6

1 Like

Are you using any ‘quirks’?

I can’t get 5.6 or even 5.2 to boot now either!

I’ll try via Raspbian to go back to an older version of the eeprom. Can’t work it out right now!

Nothing that I recall, followed the instructions here.

I did the OS uprade first and it stopped working.
After 3 cold boots hass started again.
The upgrade to 2020.12 worked but still offered the update after reboot while it showed the updated version under system.
After another reboot there were no more issues.

My C2 also did not reboot from the update from 5.7 to 5.8. I tried to do a fresh install based on the 5.8 image, but that also does not work. I connected an HDMI cable, but the C2 does not give any output at all.

My Pi 4 wouldn’t be connected to after updating the OS. Initially it showed up in the router, but after a while it disappeared, so I’m thinking it might have been just a remnant. I pulled the plug and reinserted it a few times, to no effect. Here’s what worked for me:

  1. Pulled the plug again
  2. Unplugged USB hub with Conbee stick and Ethernet cable
  3. Waited a while, still couldn’t connect (I’m not sure if it has any Wi-Fi credentials or not)
  4. Plugged the Ethernet cable back in
  5. Connected to my HTTPS DuckDNS as usual. Fixed!

I had this issue and the “root” suggestion above didn’t work for me. Manual power cycling was bringing me back into the supervisor, but without the update applied.

I managed to fix it by SSH’ing into the device and running the “ha supervisor repair” command. After this, the update ran successfully and the reboot was successful.

I followed your instructions and it works again.
But we need to know what is wrong with last update.
Can we apply it sometime soon?

So? Any thoughts?
I guess it is not normal to brick so many devices by an update.

devs more or less have answered in release thread that they are not gonna support ssd boot. They fave vslid reasons too.
Instead they encourage to use sd boot with data moved to ssd.
IMO they will promote this way, intentionally or not leaving us with decission to change approach to only proper one, or risk reliability of our installations

OK. But my setup is on SD card. Nothing to be related to SSD boot. And my system like others was bricked by this update.

1 Like

My Raspberry Pi 4 (2GB) also won’t boot after attempting the OS update. Fairly standard setup using SD card as boot. Tried multiple boot attempts with no success. Waiting for some more suggestions…

Also dead Home assistant here. Pi4 4Gb boot from SSD. Everything seem to be fine right after the update but it died at some time during the night.

After five or six hard boots I managed to bring it back to life.

Very strange indications. They sure need some explanations.

same here, update without problem from 118.5 (VM proxmox) and this night for no reason HA died, the CPU was used at 45% while normally HA uses 5%, after two reboots of the VM HA left but can this still happen for no reason?

My was up maybe half an hour after I managed to get it running again.
I once again hard booted Pi, restored 118.5 snapshot. After that was up and running I downgraded to 5.6 via terminal: ha os update --version=5.6
Not sure if this is smart, but lets see… At least it rebooted ok.