HASSIO + esphome + manual download --> error


I am having a strange issue…
When compiling a esphome yaml within the esphome addon and selecting manual download, I am getting a browser error. It tells me that the *.bin.part file can not be saved as the source file can not be read.
Wireless upload is working.
And when I am using the terminal within the esphome docker image and “esphome compile the.yaml” it also works and the bin file is created.
Seems to be a systemwide problem, as the problem persists no matter which yaml I am using?!
I am a little bit lost. Also tried a different browser to be sure that this is not a cache/cookie/browser related problem.
Does anyone know the problem?
Best regards and thanks in advance,

Full logs please.

there is nothing in the logs regarding this

Nothing in the esphome logs?

This sounds like a malware/antivirus scanner issue.
Try to disable the scanners, if you have any running.

I have a linux client, but had f-secure running. Stopping it didnt help tough :frowning:
The strange thing is, that this worked until now.

Nothing is not really correct. Nothing special, I would say:

2024-05-31 06:32:37,342 INFO 101 GET /compile ( 0.45ms
2024-05-31 06:32:37,343 INFO Running command 'esphome --dashboard compile /config/esphome/klo-vorne.yaml'
2024-05-31 06:32:40,572 INFO Process exited with return code 0
2024-05-31 06:32:40,612 INFO 304 GET /downloads?configuration=klo-vorne.yaml ( 0.61ms
2024-05-31 06:32:40,659 INFO 200 GET /download.bin?configuration=klo-vorne.yaml&file=firmware.bin&download=klo_vorne.bin ( 2.55ms

You could transfer it over the network with scp or samba I guess.

this is what I am doing. terminal and scp, but this is not really conveniant

Just installed 2024.5.5 → Download is working again. strange