Hassio external hd

Hi all,

previously i run a rasbian on a raspberry pi 3 b and home assistant from virtual enviroment, all installed on a external usb hd. The HD is a PiDrive of WD, this:

Now I have a new raspberry pi 3 b +, and I run hassio from sd card. Can I use a PiDrive instead of sd card???

Not with HassOS.

Noooo :cry:
So for have more storage and also power I have to move hassio in somethink like nuc?

Not necessarily. It’s just HassOS won’t boot from a USB stick so you need something like Raspbian booting off USB and then a Docker install and then Hass.io as a generic Linux install instead of using HassOS which is provided here out-of-the-box with Hassio images.

Oooh OK, but I haven’t absolutely experience with docker… It’s difficult to install? There is some guide?

See here Hassio for Raspberry Pi 3 B+

Use Dale3h’s script.

Wow tomorrow I’ll try! Thank you so much. I only have to do all this procedure on external hd…

You need to do a linux install on the hd and be able to boot from that then use dale’s script.

1 Like

Dear DavidFW1960,
I made the docker installation as your suggestion. Now hassio is running without sd on my raspberry on the external 250GB hd. That’s great. All seems work, apart Grafana. I restore the previous setting but Grafana can reach the InfluxDB database, and give me this error:
Network Error: Bad Gateway(502)
But all the configuration is the same… I don’t understand why this happen, can you help me?

This is in Grafana log:

2019/02/21 21:59:19 http: proxy error: dial tcp: lookup xxxxxx.duckdns.org on read udp> i/o timeout t=2019-02-21T21:59:19+0100 lvl=info msg=“Request Completed” logger=context userId=1 orgId=1 uname=xxxxxx method=GET path=/api/datasources/proxy/1/query status=502 remote_addr= time_ms=10016 size=0 referer=https://xxxxxx.duckdns.org:3003/datasources/edit/1

Solved :joy:

The URL of the datasource must be: http://a0d7b954-influxdb:8086