Hassio folder proxmox installation location

Hello guys ’
i installed home assistant on proxmox follwoing the script guide. i would like to access hassio folder from my win 10 machine using smb but not the addon so i setup smb on linux vm in proxmox but when i tried to locate the hassio folder i cant find it i tried this path but it is not existe


any idea where the location could be ?

Try /mnt/data/supervisor/*

thanks for replay i tried it but it seems not there

rootshell@myprox:/mnt$ cd /mnt/data/supervisor/
-bash: cd: /mnt/data/supervisor/: No such file or directory
rootshell@myprox:/mnt$ ls

It looks to me like your are executing the commands on the Proxmox host, not inside the VM. Is this shell from the proxmox host or the VM?

1 Like

It is from putty using proxmox ip
How i can excute it inside VM?

Click on the vm in the list in the proxmox Web ui and click the console button (top right)

Or from putty, use the ip address of the vm not the host.


So samba should be installed in vm not proxmox it self ?

Ideally, if you’re using homeassistant in the old ‘hassio’ way you should use the samba addon I believe.

Thats right but i would like to be able to access hassio files from outside home assistant in case home assistant goes down and smb addon broke

You need to SSH into the VM.

I don’t know your Proxmox setup, I configured iptables to change the SSH ports for my VMs.

Are you running other VMs on Proxmox or only Home Assistant? If it is only Home Assistant, why did you not install the NUC image? Do you want to have Home Assistant Supervised for a reason?

You can also login to the VM shell through the proxmox web interface by clicking on the VM and then Console.

Currently only running home assistant Vm.
I will try install samba using Consol from proxmox webui
Is there any good guide on how to install nuc image into old pc ?

1 Like

Thanks Mate

Hey @rootshell1989,

Did you get this working without the Samba addon?

Nope. I installed the smb addon