Hassio Homekit Garage door device class issue

I installed tasmota on a sonoff basic to control my garage door. A transistor at GPIO-Pin 14 will trigger the door to open/close. So I use the transistor (with a 2kOhm resistor as a switch). This switch hat to be open vor some milliseconds. I do this with a script in home assistant.

Also I connected a reed sensor do GPIO1, to measure if the door is opened or closed.

This all works fine within the home assistant gui. But when I link it to homekit it it is unavailable as long as the device_class is garage.
So when I delete device_class: garage, is is shown and controlable within the homekit gui.

So why is it not possible to add the device class here

- platform: mqtt
name: “Garagenzustand”
state_topic: “tele/sonoff/SENSOR”
value_template: ‘{{ value_json[“Switch1”] }}’
force_update: true
- platform: template
garagenzustand_tf: #true false
value_template: “{{ is_state(‘sensor.garagenzustand’, ‘ON’) }}”

  - platform: template
        friendly_name: "Garage"
        value_template: "{{ states('sensor.garagenzustand_tf') }}"
          service: homeassistant.turn_on
            entity_id: script.garage_script
          service: homeassistant.turn_on
            entity_id: script.garage_script

        name: Garage2

  #friendly_name: Garage
  device_class: garage ## WORKS when I delte this, but does not show as garage in homekit


It looks like this with device_class: garage

Did you find a solution to this problem?

Unfortunately not. Are you facing the same issue?

Yes, exactly the same issue.

Same problem here.

I had the same problem and was able to get it fixed. The homekit save the device settings in the first time it loads so probably when you first started setting up your garage it was not selected the class yet and homekit saved that config as blinds.
So you have to delete the device from homekit so it can be loaded again with the new settings and the class as garage. Easiest way to do it is to add the device in the homekit exclusion filter and restart HA. After you confirm it was erased from home app, just take it off the exclusion filter and restart HA again. Now check your home app and you will have a garage door icon!!!


I get the same issue.

I’ve tried removing as above, but it still shows a blinds.

Any other ides?

thanks, it solved my problem…

1 Like

That fixed it for me but I also found this that homekit.reset_accessory would have done the same thing.

1 Like

Yes but it’s a brand new service which didn’t exist in previous HA versions.

for the life of me I can’t seem to be able to reset an entity. The explanation there seems to be pretty straight forward, but when I invoke that service, home assistant won’t do a thing. Do we need a special syntax whatsoever?


Took a bit for me to figure this out so putting it here for anybody else that googles looking for the format.

After you select homekit.reset_accessory set your entity id by setting the following in the yaml section (in my case basement tv)

entity_id: media_player.basement_tv


Have you found a solution to fix this issue? I am also facing the issue as well. I tried to remove the bridge from Home app and configure them again, but it didn’t work. It still shows it as a blind.