Hassio inactive

I am fairly new to Home Assistant. I am running Windows 10 and have connected my Rasbery Pi 3 via ethernet cable to my router.

I have been having problems with Hassio not connecting. I made some changes to Hassio (setting up Mosquitto) and restarted the server after verifying my code which was valid. Hassio took a long time (more than 10 minutes). So, I decided to stop and restart. It did not work. All of a sudden, Hassio was completely gone offline. My router shows Hassio’s status as Inactive and not connected. I tried turning it off by unplugging it and turning it back on, but still no luck.

Any help is much appreciated

Instead of troubleshooting this, I would suggest that you move a new Hass.io image to your SD card and then re-install the add-on.

It’s far less time consuming to start from scratch than trying to figure out what wrong if you are not familiar with Docker or in fixing a maybe filesystem on your SD card.

@fabaff Thank you for your advice. This is not the first time I have had the misfortune. I just want to know what the root cause is so I can deal with it in future. In the mean time, I will take your advice

There is a section in development documentation about the Debugging of Hass.io


Perhaps this could help.