HASSIO Installation Issue - Preparing Hass.io (this can take up to 20 minutes)

Hey,

I have no fckn idea what to do. I have an Raspberry Pi B+, downlaoded the image for RPi1 from the official site. Flashed it with Etcher, tried to update the sample config for a static IP, tried wifi, tried lan cable, but all I got is the “Preparing Hass.io
(this can take up to 20 minutes)” website. Was waiting for hours between all the tries.
It’s just annoying :frowning:

You’re already making more progress than my installation. I followed the same instructions, tried the same variations as you did – and I never get beyond the initial splash screen. Eventuallyh the Raspberry Pi’s screen blanker comes on and that’s it folks. Nothing ever happens after that.

@MarkHargrove That’s expected on the Raspberry Pi’s video output; all you’ll ever see there is the HASS splash screen. Hassio is a server, intended to run headless. Once you’ve gotten to that part you need to go to a web browser on a different computer and navigate to either http://hassio.local:8123 or http://your.raspberry.pi.ip:8123.

1 Like

If you want a more traditional “here’s a login prompt” outcome, then Hassbian is what you’re after. HassIO doesn’t give you a login prompt, and all your initial setup is done with a web browser.

Any help according the original problem?

Are you trying to connect, with your web browser, to either http://hassio.local:8123/ or http://192.168.0.2:8123/ (replace 192.168.0.2 with the IP of your Pi)?

As has been mentioned here - that splash screen won’t change. There is no local login option.

Yes, i am trying to connect via browser. And all I see is the “preparing hass.io - this can take up to 20 minutes”. And this will never go away. I used the default resin-sample and custom ones from the documentation. With wifi and ethernet. Nothing works.

Mine was stuck at that screen until I unplugged the HUSBZB-1 USB stick that I use for zwave and zigbee. Then it completed booting and I plugged the stick in and it’s worked fine ever since. Do you have any peripherals plugged in?

Have you tried just flashing the image and inserting it into the pi (ie not modifying any config files)?

I’m not sure if this will work or not, but if you plug the pi into a monitor and attach a keyboard, you may be able to hit escape at the splash screen and get the console output to see what step its hanging at.

Do you have any peripherals plugged in?

Nope.

Yes.

I’m currently having same issues. In a fresh install of Hass.io after more than 1h I can only see the splash screen and I cannot access to http://:8123 or http://:8123

Any suggestion?
Thanks in advance

Regards

To confirm, you’re unable to reach it with http://hassio.local:8123/ or http://192.168.0.9:8123/ (replacing 192.168.0.9 with the IP address allocated by your router (or other DHCP server).

Are you using the proper power supply?

For me hassio.local doesn’t work but with the IP address of the Pi it does work. That was with al LAN cable. I’m now trying to setup the Wifi, but changing the resin-sample like I succesfully did on the Pi 3 doesn’t work with the Pi B+ with a wifi dongle. Does anybody have suggestions?

I am having similar issues also.

Last night I couldn’t login using hassio.local:8123, but could using the ip that my router showed. I tried to add Samba and SSH but they never showed as installed.

This morning, I turned on the Raspberry Pi and I could log into hassio.local:8123, both Samba and SSH showed up as installed and I could access files from Windows 10.

But the icons that are normally in the upper right corner of the screen are not there. The config tab does not work (just shows a rotating circle), the log does not work. The history tab doesn’t work,

Once I get my other computer back I will try to load an older version of Hassio to see if it was something with an update.

Thanks.

Hi,

I have almost the same issues.
Tried to install / create an image for a Raspberry 3. they all failed.
A manual install failed as well. I can access the raspberry with SSH.
Never I have been able to access the DHCP server.

Somewhere something is not working.

Greetings

Has anyone managed to make this work?

yes, i had the same issue, but disconnecting usb keyboard and mouse and rebooting the pi made it work for me,

Just sharing my experience with this issue.

I tried to install Hass.io on my RPi 3b+ on 2 occasions in different networks, namely my office and home. First attempt in the office worked well, but I could not replicate the success at home. It got stuck at “preparing hass.io” page for the longest time. This morning I brought the same set up back to office, and it managed to complete the preparation phase within 10 mins.

I believe it should have something to do with my router at home, maybe the anti-virus was blocking connection or something. I’m using TP-Link Deco m5 btw.

I wonder if this is a router issue. I’ve installed on multiple memory cards, multiple Raspberry Pis and always stuck at “Preparing Hass.io”.

A Google search reveals that it’s a pretty widespread problem and I can’t see a documented solution.

I’ve the same issues here. Situation:

  • Brand new Pi 3B+ with a 4A power supply
  • Brand new 32 GB MicroSD card (Samsung EVO Plus)
  • Used balenaEtcher with 32-bit HASS.io image to prepare SD-card (image: hassos_rpi3-2.8.img.gz)
  • Started the installation process without any USB-stick/connection attached

The message within the browser “Preparing Hass.io (this can take up to 20 minutes)” doesn’t change, even after hours of waiting.
I’ve attached a display to the Pi and the installation process gets stuck in an endless loop stating the following two lines every ~10 minutes:

  • IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
  • brcmfmac: power management disabled.

Does anyone have an idea how to solve this issue?

1 Like