Hassio installation Odroid HC2 from script did not go well, why?


I have installed Hassio form script as described on:
https://github.com/home-assistant/hassio-build/blob/master/install/README.md, I used as my_machine odroid-xu.

I did it on Rpi3, ODroid C2 all good but I run it on Archlinux on Odroid HC2 and somehow it not install well. I can log in to HA and I set up user and password but and up with plain HA with Hassio error:

Invalid config
The following component could not be set up:

  • Hassio

Please check your config.

So I have added hassio: to configuration.yaml, rebooted and the same again.

So what went wrong:

From docker logs hassio_supervisor:

18-11-30 07:02:23 ERROR (MainThread) [hassio.homeassistant] Error on call 18-11-30 07:02:23 WARNING (MainThread) [hassio.tasks] Watchdog 
miss API response from Home Assistant 18-11-30 07:07:23 ERROR (MainThread) 
[hassio.homeassistant] Error on call 18-11-30 07:07:23 ERROR 
(MainThread) [hassio.tasks] Watchdog found a problem with Home Assistant API! 18-11-30 07:07:23 
INFO (SyncWorker_34) [hassio.docker.interface] Stop homeassistant/odroid-xu-homeassistant 
Docker application 18-11-30 07:07:28 INFO (SyncWorker_34) [hassio.docker.interface] Clean 
homeassistant/odroid-xu-homeassistant Docker application 18-11-30 07:07:34 INFO 
(SyncWorker_35) [hassio.docker.homeassistant] Start homeassistant homeassistant/odroid-xu- 
homeassistant with version 0.82.1 18-11-30 07:19:11 WARNING (MainThread)        
Don't wait anymore of Home Assistant startup! 18-11-30 07:19:11 ERROR (MainThread) 
[hassio.tasks] Watchdog Home Assistant reanimation fails!

docker logs homeassistant:

2018-12-01 01:08:53 WARNING (MainThread) [homeassistant.setup] Setup of hassio is taking over 
 10 seconds. 2018-12-01 01:08:53 ERROR (MainThread) 
 [homeassistant.components.hassio.handler] Timeout on /supervisor/ping request 2018-12-01 
 01:08:53 ERROR (MainThread) [homeassistant.components.hassio] Not connected with Hass.io 
 2018-12-01 01:08:53 INFO (MainThread) [homeassistant.setup] Setup of domain hassio took 10.0 
 seconds. 2018-12-01 01:08:53 ERROR (MainThread) [homeassistant.setup] Setup failed for hassio: 
 Component failed to initialize. 2018-12-01 01:08:53 INFO (MainThread) [homeassistant.bootstrap] 
 Home Assistant initialized in 14.64s 2018-12-01 01:08:53 INFO (MainThread) [homeassistant.core] 
 Starting Home Assistant 2018-12-01 01:08:53 INFO (MainThread) [homeassistant.core] 

As I am using archlinux I reckon all packages are new, docker is Server Version: 18.09.0-ce.

I did not install only network-manager (but the same was on other machine and it worked).
I am using Portrainer to monitor my containers (not to start them). I can see that homeassistant and hassio_supervisor are running, logs looks all good apart of quoted parts so…

It seems to be nearly working but I missed something and Hassio_supervisor is not connecting with HA,

Could anybody help me to get this run, please?

Anyone please? I am newbie and stuck what could be wrong?