HASSIO internal Docker dns routing to wrong DNS when installing Add-ons

I just recently after one of the new updates could no longer update some of my plug-ins. I noticed the log kept giving me a “No Route to Host”

I found items like Community Add-Ons like ESPHome installs with no issue. I assume its not a docker container using the internal docker container dns of

However all fails and reference “https://ghcr.io/v2/”: dial tcp :443: connect: no route to host"

EDIT: FIXED THIS ISSUE. I had the VLAN20 set to Needed a subnet mask of 24 and all works great now.

From terminal plugin in HA I can’t ~$ ping

Found the error when running terminal in HA
~$ traceroute
traceroute to (, 30 hops max, 46 byte packets
** 1 d7b954-nodered.local.hass.io ( 0.004 ms 0.003 ms 0.001 ms**
** 2 ( 3081.201 ms !H 3070.861 ms !H 3071.967 ms !H** is my actual VLAN IP of the Homeassitant. Anyone know how to get this directed to the correct dns of

In my network setting under supervisor host I have (2) IP’s

eth0 - DHCP (Its static on my router
eth0.20 - Static (IP:, Gateway:, DNS:

This should be referencing or

Changed subnet mask for VLAN to from /8 to /24 and all works great now.