Hassio list bluetooth le devices?

i installed hassio on a pi 3 and added the Bluetooth add-on, but i can’t seem to find a way to list nearby Bluetooth le devices.
i tried to login with ssh and use hcitool but i just get a not found error…

Is there any way?

1 Like

I’m looking for the same answer. Have you found it yet?

1 Like

After installing the bluetooth addon and starting it, you still need to add the bluetooth component to your config yaml:

  - platform: bluetooth_tracker

Then I put my phone into bluetooth pairing mode near my Pi3 and rebooted (actually I forget if I restarted HASS or rebooted the Pi).

When it came back up I saw my phone and some other devices in range in the UI and listed in known_devices.yaml with their BT_mac addresses.


Thanks to your suggestion the bluetooth module seems to be running now (after a restart of the Raspberry Pi3):

starting version 3.2.1
Flash firmware /lib/firmware/brcm/BCM43430A1.hcd
Set Controller UART speed to 115200 bit/s
Device setup complete

Unfortunately I still don’t see any of my Bluetooth LE devices (MiFlora plant sensors). Any ideas how get these to work?

1 Like

The Bluetooth device tracker and the Bluetooth LE device tracker are two seperate components, so try adding the following to your configuration:

  - platform: bluetooth_le_tracker

Doesn’t seem to work as intended:

2017-08-05 11:30:34 ERROR (MainThread) [homeassistant.components.device_tracker] Unable to load /config/known_devices.yaml: Config file not found: /config/known_devices.yaml
2017-08-05 11:30:44 WARNING (MainThread) [homeassistant.setup] Setup of sensor is taking over 10 seconds.
2017-08-05 11:30:44 WARNING (MainThread) [homeassistant.setup] Setup of device_tracker is taking over 10 seconds.
2017-08-05 11:30:47 WARNING (MainThread) [homeassistant.setup] Setup of tts is taking over 10 seconds.
2017-08-05 11:30:54 WARNING (MainThread) [homeassistant.components.sensor] Setup of platform homematic is taking over 10 seconds.
2017-08-05 11:31:26 ERROR (SyncWorker_15) [homeassistant.util.package] Unable to install package gattlib==0.20150805: Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-build-w3vt50dq/gattlib/
2017-08-05 11:31:26 ERROR (MainThread) [homeassistant.setup] Not initializing device_tracker.bluetooth_le_tracker because could not install dependency gattlib==0.20150805
2017-08-05 11:31:26 ERROR (MainThread) [homeassistant.setup] Unable to prepare setup for platform device_tracker.bluetooth_le_tracker: Could not install all requirements.
2017-08-05 11:31:28 ERROR (MainThread) [homeassistant.core] Error doing job: Task exception was never retrieved

Maybe the add-on is only designed for Bluetooth tracking and not Bluetooth LE tracking. I don’t use Hass.io myself, so I don’t know for sure.

I would guess that the bluetooth addon for hass.io is only satisfying the requirements for bluetooth and not LE. LE requires installation of pybluez. The lack of LE may be related to the warning which appears on the bluetooth LE page? Though I have seen comments in respect to non-LE bluetooth implying that it is also a potential source of slowdown…I suppose it all depends on what hardware you are running.

Sounds like a reasonable explanation. However, it is not stated anywhere in the documentation.

Does anybody know who is in charge of that addon and might have some interest in looking into this issue?

Any news regarding Hass.io and Bluetooth LE support on Raspberry 3?

1 Like

anyone solved this?
I have rp3 with hassio and want to add one mi flora…

I’ve just changed to Hassio too and missing Mi Flora support. Anyone got it working or is it currently not supported?

Sounds like it will come in next release:

Commits on Aug 03, 2017
@pvizeli pvizeli Update create_homeassistant_generic.sh 2bfc284
@pvizeli pvizeli Refactory hass docker (#25)
@pvizeli pvizeli add glib library f98548e
@pvizeli pvizeli add bluepy

Commits on Aug 14, 2017
@pvizeli pvizeli Add bluez library

Just wait for 1.1 release with fingers crossed :wink:


New release is out, but it seems that bluez libs haven’t been included, yet:
release notes 0.52

It was committed in the master branch…
So should be ?
Or correct me if I’m wrong.

HomeAssistant 0.52 was released but it’s not the same as Hass.Io which is still in version 1.0

The BT LE seems to be supported in Hass.io v 1.1 release but the changes are not commited yet in master branch, or even if they are a new release is not yet out unfortunately :frowning:

HAss.IO release 1.0 could support any HA version it’s like a debian OS for example your OS could support firefox 32 and 33 without updating itself :wink:

Out of interest where are you seeing the version numbering for HASS.IO? my hass install just shows the Home Assistant version (0.52) and no mention of the HASS version.

You can see the hass.io version under [your hassio]/hassio/advanced:

1 Like

Thanks for that :slight_smile:

Any ideas when BLE will be supported on Hassio for RPI? Also have miflora sensors that I need to connect to…