Hassio.local:8123/ not working on iPad anymore

I get the Home Assistant title and Icon and then a line that says “Initializing” and that’s it.
Tried Safari and Edge. Same results.
Works fine on Chrome and Edge on my Windows 10 PC and prompts for username and password.
But I never get the prompt on the IPad anymore.
Home Assistant 0.91.3
Help, please !

Use the actual IP.

Hassio.local is depending on that hostname resolving in your router. Many people have issues with it.

Also, a large part of the front end is cached. The intializing screen can appear even if it cannot connect. Try using clearing your cache or using the ‘private’ mode in your browser and it should show its not connecting at all.

Cleared cache: same result - “Initalizing”
Cleared everything about Safari: same result - “Initalizing”
Tried IP address: same result - “Initalizing”
Private Mode: Same result - “Initalizing”

Did the same in Edge: same result - “Initalizing”

Interesting, not a dns issues then.

Do you have ip ban enabled or any other special setup in your http: section of the config file?

This is all I have in that section (its all disabled):

# Uncomment this if you are using SSL/TLS, running in Docker container, etc.
# http:
#   base_url: example.duckdns.org:8123

I just tried it on an old iPhone that’s never been used before to access Home Assistant, and it came up fine with the Username and Password Login screen.
Very strange…

Using Safari

I think something changed in 0.91.3 that broke this…

Don’t do this, it mucks up older IPads. configuration.yaml

  javascript_version: latest

Problem resolved!

1 Like

that works! even a year later.

Unfortunately not for me in 2020 … still only a blue and white stripe

@haegar33 Any luck on this? I am running into the same issue on my iPad. I can log in via my compuer, my iphone and my wife’s iphone but the iPad (iOS should be up to date). Attempted to log into the Home Assistant for the first time on an iPad and it was stuck on the initialization screen. If I attempt to log in via chrome I get a blue strip on white background.

No progess. Issue ticket on github is now ignored. Its a tricky and maybe even random connection error thus I understand that many programmers cannot reproduce the situation.

Even more strange: I digged out my old iPad2 on iOS 9 and it works! Its only one newer iPad which does show the white an blue stripes.

The log just repeats the message that this device is not authorized despite the fact that I disabled all login features in my LAN:

2020-10-31 12:28:59 DEBUG (MainThread) [homeassistant.components.http.view] Serving /api/discovery_info to (auth: False)
2020-10-31 12:29:09 DEBUG (MainThread) [homeassistant.components.http.view] Serving /auth/providers to (auth: False)
2020-10-31 12:29:09 DEBUG (MainThread) [homeassistant.components.http.view] Serving /auth/login_flow to (auth: False)
2020-10-31 12:29:10 DEBUG (MainThread) [homeassistant.components.http.view] Serving /auth/token to (auth: False)
2020-10-31 12:29:12 DEBUG (MainThread) [homeassistant.components.http.view] Serving /api/websocket to (auth: False)