Hassio loses connection to Deebot robot vacuum

Hi all,

I have a Deebot N79S that I configured with my Home Assistant setup and it works fine, the only problem I have is that Hassio loses connection to the Deebot and I can’t control it anymore. I get errors like
Failed to call service vacuum/turn_on. <iq id="blabla"....>.

Presumably, Hassio doesn’t try to reconnect to the deebot when the connection is lost, I have to restart Hassio in order to get it working again.

All help is much appreciated.


I’m new to HASSIO… I just got today the Deebot N79S… but I can’t get it to work! can you share what you have on your configuration file to see what I’m missing…

this is what I get:
Error during setup of component ecovacs
7:47 PM components/ecovacs/init.py (ERROR)


Well, first you have to setup the deebot with your smartphone app (I personnally use the Android app) to set up an account and connect the deebot to wifi, then you need to set a new ecovacs component in your configuration.yaml file

  username: "replace with your email"
  password: "replace with your password"
  country: "fr"
  continent: "na"

Restart home assistant, and after that, create a new card in lovelace ui with the entity
vacuum.e123456789123456789 (or whatever deebot ID it detected)

Thank for the reply!
I have it like that:
username: !secret deebot_username
password: !secret deebot_passworld
country: us
continent: na

but I still get that error… so I don’t know what is going on with mine that doesn’t work…

I just purchased a DeeBot and I am experiencing the same thing… Has anyone solved this?

required fields

  username: !secret debot_username
  password: !secret debot_password
  country: UK
  continent: EU

Works fine for my new Debot N95S

Spelling? deebot_passWORLD?