Hassio new installation asking for username and password

My original attempts are here.

now trying with hassio. I’ve managed to find a way to find out the constantly moving IP address, by going through my router information. But when I do reach the IP address for the raspberry Pi 3 with hassio SD card, it is asking me for username and password.
Any advice appreciated, Tremulous Tetra. :slight_smile:

Open your configuration.yaml file and look for api_password:

Whatever is written in front of it is you password.

complete Newbie

So I take the SD card out of my raspberry Pi, put it into my PC, search for the file called "configuration.yaml, then read that file using notepad?

No. You connect to your Pi via Samba or FTP and look for a folder called “config” (usually on the root folder) and “configuration.yaml” is inside it.

What OS are you using?

1 Like

On the SD card is hassio.

I’m on a Windows 10 PC.

Can you point me in the right direction for software for Windows 10 PC, to contact the raspberry Pi using either Samba or FTP please?

Any advice appreciated, Tremulous Tetra. :slight_smile:

tried this, got nowhere

Any advice appreciated, Tremulous Tetra. :slight_smile:

Open Windows Explorer and under “Network” find a share called “HASSIO”

this is what I get listed, no hassio :frowning:


I am seem to be having a lot of problems, could it be because I have the raspberry Pi 3 connected to 1 of these

Any advice appreciated, Tremulous Tetra. :slight_smile:

That could be the problem. Are you using fixed IP? If not try this:

“Optional - Setup the WiFi or static IP: On the SD-card, edit the system-connections/resin-sample file and follow the ResinOS howto.”


just got my daughter to plug it straight into the router (my hands are paralysed) and it still has the same problems.

I will have a look at your new setup option.

Thank you

Any advice appreciated, Tremulous Tetra. :slight_smile:

back to the same problem, how do I edit those files?

So I take the SD card out of my raspberry Pi, put it into my PC, search for the file called “connection file”, then edit that file using notepad?

Edit the “system-connections/resin-sample” file with notepad.

Setting a static IP is possible by adding a few fields to the [ipv4] section of your connection file.


How would he connect via samba if he hasn’t got into it yet to install the add on?

1 Like

There’s no password by default so you’ve either got further than your saying and added one yourself or something has gone very wrong with your install.

Either way, just erase your SD card and start from scratch.

Set up an IP reservation on your router for the pi’s MAC, far easier than messing about with the resin config.

I tend to lean towards the idea that something has gone very wrong with the install. The problem is I have no idea what.

All I have done is burned the programme from the website, which I have downloaded twice to make sure there was no problem with the 1st 1.

I then burned the program to the SD card with etcher.

Put the SD card in the raspberry Pi 3, and left it for half an hour.

I then go to my IP address for this device, which I find by looking on my router, with the :8123and I get the screen in my web browser which I posted earlier.

That’s it, that’s all I’d done.

I have also tried plugging the raspberry Pi Straight into my router, thinking the power line lan might be the problem. No change.

tried again downloading. Triedtwice burning it to the SD card, put it in the raspberry Pi, switched it on, with the network cable plugged straight into the router, and left for one hour. Same problem, the screen is asking for username and password.

The raspberry Pi 3 works fine with the normal raspbian.

Any advice appreciated, Tremulous Tetra. :slight_smile:

I’ll jump in and try to help.

Just to be clear, for your Raspberry Pi 3, this is the file that should be downloaded and burned to the SD card with Etcher:


After you boot up the Pi and wait 30 mins or so, you should be able to access the installation by going into a web browser and typing:


The Home Assistant main screen should just load - there’s no password by default. I’m wondering if it’s asking for one because you’ve been accessing via IP address and not the hassio.local address.

yes that is the file I downloaded last night.ought to be absolutely sure, I will burn the 1 you gave me the link to now.

when I use the semicolo
I get the error message;
Cannot reach this page
•Make sure the web address http://hassio.local:8123 is correct
•Search for this site on Bing
•Refresh the page
More information More information
Fix connection problems

Again just to be absolutely sure, the address is:


(that is, the port number is 8123)



(the port number is not 81231).