Home Assistant Community

Hassio Not connecting to network

#1

After more than a year, my Hassio stoped working. I powered cycle Raspberry pi few times but it’s still can’t connect. I made sure the Ethernet cable is connected. . I previously made few backups but not sure where Hassio stores the backup file.
What should I do know?
Thanks.

0 Likes

#2

Go back in time and make regular snaphots and regularly copy them off the SD card to a secure location.

If your time machine is not functioning you can attach a monitor to the HDMI port of your Pi and check the boot messages.

You can also try putting the SD card in a PC and read off the config and backup partitions. You will need either a Linux PC or software capable of reading a linux partition to do this.

Check the log file for errors. If nothing is evidently wrong you can make a new SD card image and restore from snapshot.

0 Likes

#3

Thanks for the reply. I was able to view the Linux folders using a Linux partition software.
I backed up the 2 folders that I think I will need in case I need to recover. The two folders are Homeassistance which contains all the .YAML config and the second is the backup file.

I found only 1 file with .log and the only error I see from is from my Blink camera but this error is been happening since when I linked my blink camera to Hassio and is been couple month, and my Hassio stoped working just yesterday. I don’t this it’s the problem.
But anyways how do I edit and delete in the config YALm the blink camera and import it back.
I am not sure about that. I could export the YAML to my desk to and edit but can’t import to the SD card?

Any other suggestion before I create a new image Hassio.

Thanks a lot.

0 Likes

#4

The SD card is protected I can’t creat a new image.
I was reading that it could be the log file full. How do I detete the log using window 10.

0 Likes

#5

You won’t be able to do that if the card is protected.

Are you using a microSD to SD card adaptor to read the card?

If so, there might be slider on the side of the SD card adaptor to set it in read/write mode:

0 Likes

#6

I tried all the methods so far, I checked for the lock, I tried 3 or 4 softwares and tried CMD command. but nothing works. I guess I have to buy another one. Although I was hopping to make it work. I don’t was to give up on this SD card.
any idea how to get access to the log and deleted it or edit the config file.
I was able to use a linux software to back up my file ( that is good) but I cant edit.

0 Likes

#7

If you save the snapshot from the SD card to disk you can extract the tar file to find homeassistant.tar.gz. Again extract the files from this and you should see your config directory containing all your configuration files and the log.

I use 7zip (freeware) on windows 10 to do this. Note if you want to re-compress the files on windows you’ll need something like winrar (not free).

0 Likes

#8

thanks for the help .
I bought a new SD card and used the backup. Now I have few errors that is preventing me to reboot my raspberry for updated.Basically a lot of Recorder error how do i fix it ?

Setup failed for recorder: Component failed to initialize.

April 14, 2019, 1:02 PM setup.py (ERROR)

Error during connection setup: (sqlite3.DatabaseError) database disk image is malformed [SQL: CREATE INDEX ix_states_entity_id ON states (entity_id)] (Background on this error at: http://sqlalche.me/e/4xp6) (retrying in 3 seconds)

April 14, 2019, 1:02 PM components/recorder/__init__.py (ERROR) - message first occured at April 14, 2019, 1:00 PM and shows up 10 times

Error executing query: (sqlite3.DatabaseError) database disk image is malformed [SQL: CREATE INDEX ix_states_entity_id ON states (entity_id)] (Background on this error at: http://sqlalche.me/e/4xp6)

April 14, 2019, 1:02 PM components/recorder/util.py (ERROR) - message first occured at April 14, 2019, 1:00 PM and shows up 10 times

Database is about to upgrade. Schema version: 6

April 14, 2019, 1:02 PM components/recorder/migration.py (WARNING) - message first occured at April 14, 2019, 1:00 PM and shows up 10 times

Setup of recorder is taking over 10 seconds.

April 14, 2019, 1:00 PM __main__.py (WARNING)
0 Likes

#9

Sounds like your database file is corrupted. Stop HA and delete the database file and restart HA.

0 Likes

#10

where can I find the data base file, is it in the config file?

0 Likes

#11

it is in the config directory. It is called home-assistant_v2.db

0 Likes

#12

Thanks a lot, I guess that helped with my recorder and history errors
Now I am still having issues with:

  1. when I restart the hassio I dont see the changes. For example I have a lot of notification on the overview that I hide using Customize eg:
    sensor.hallway_nest_protect_co_status:
    hidden: yes

  2. I use Cover: for my garage and it works fine but the configuration seems not to like see log in line 578 please :

    Error doing job: Future exception was never retrieved

    8:46 PM components/konnected/init.py (ERROR)

    Konnected device 60019438a5df was discovered on the network but not specified in configuration.yaml

    8:46 PM components/konnected/init.py (WARNING)

    BadRequest (401) unauthorized http://10.0.1.41:32400/; <html><head><script>window.location = window.location.href.match(/(^.+/)[^/]*$/)[1] + ‘web/index.html’;</script><title>Unauthorized</title></head><body><h1>401 Unauthorized</h1></body></html>

    8:40 PM components/plex/media_player.py (WARNING)

    Error doing job: Task exception was never retrieved

    8:40 PM helpers/storage.py (ERROR)

    Unable to remove unknown listener <function async_track_point_in_utc_time.<locals>.point_in_time_listener at 0x7590e348>

    8:40 PM core.py (WARNING)

    Your configuration contains extra keys that the platform does not support. Please remove [optomistic]. (See /config/configuration.yaml, line 578).

    8:40 PM helpers/config_validation.py (WARNING)

0 Likes