Hassio not starting up after multiple fresh install

Tags: #<Tag:0x00007f73b4b76ce8> #<Tag:0x00007f73b4b76568>

Hi,

I have installed Hassio on raspi4 B 8gb as well as raspi zero-w but not able to run it even after waiting for more than 40-45mins. I get continuous errors on the cli screen that Hassio port continuously changes it’s state (disabled-blocking-forwarding) and also changes the port number. After 30 min I get the web console response stating “Preparing Home Assistant” and “failed to load cookie file from cookie: no such directory found”. Tried multiple fresh install and multiple Hassio versions but still the same. This was a serious bad decission of upgrading Hassio after which I am facing this issue.
Trying this from last 4-5 days but landing up nowhere with a resolution.

Please help me out with a solution. I am not able to control my devices now :frowning:. Also I am able to run ubuntu with the same sdcard so sdcard semm to be working fine. There is something wrong with Hassio I guess.

Thanks in advance, Mehul

I have the same problem…

  • Clean install
  • Watching the “Preparing Home Assistant” screen
  • Error pops up: Failed to load cookie file from cookie: No such file or directory
  • Nothing happens anymore…

How did you fix it?

1 Like

Maybe delete cookies in browser…? And restart the browser…

Im brand new to Home Assistant (coming from HOOBS) Trying to set up today and have had the exact same issue. Clean install, default network settings (ethernet), Error pops up, just sits there.

:frowning: Any other ideas for what to try to fix?

You could try the beta release version of HA OS HERE. Specifically, the 64bit version for the Pi4.

You could also try the 32bit version, but that will most likely limit you to 4gb of RAM, which is more than enough for HA anyways - it very happily runs on 2gb RAM.

HA is not designed to run on a Pi zero and will likely take hours to startup - the hardware is not powerful enough. Stick with the Pi4.

I was able to get in… I just needed to power cycle the PI (4 running 32bit) and then connect via the IP address instead of the using “home-assistant.local:8123”

I could try installing 32bit version but I guess it won’t support on 8gb rpi4 version. Interestingly while my system was busy blocking port states, I clicked enter after which I got login option for cli and entered with default root login and then entered command “core stop” and then “core start”. After which I am able to access the web-console and enter the add-ons as well. But this is just a workaround, you will have to do this same process everytime after boot to get the web-console. Hence, for this u always require a monitor and a keyboard to start Hassio.:man_shrugging:t2:

If anyone gets a solution for this please do let me know.