HASSIO OS still active but cannot access interfacce

Hey Guys,

im in a pretty bad Situation where I dont know how to get out.

I run Homeassistant OS on a RPI 4b with 2Gb (but its not a Hardware Issue as I changed the Pi and its still the same).
The Pi boots and connects to Wifi (or Ethernet, but usually Wifi works fine). It still does all the automations. But I cannot access the Interface anymore. Neither on a mobile phone in the Wifi nor on a PC (via Ethernet or Wifi).
Connecting to the IP provided by the Router it simply says ERR_Empty_Response. Connecting to homeassistant.local:8123 does the same.

I cannot point out why exactly this probaply happened as I did multiple things recently. Connecting via SSH doesnt work as I havent set it up. I ordered a Micro HDMI adapter to check out its graphical Input, but maybe someone else can help me.

Is there a way of accessing the backup files without the Interface?

Can someone help me out ? I searched around but havent found anyone else with this issue recently