Hassio + Raspberry Pi 2 Model B + WiFi Dongle

Tags: #<Tag:0x00007f739f453368> #<Tag:0x00007f739f4532a0>

Hi,

I’m new to Raspberry Pi, Linux, and Hassio/Home assistant so I would like to ask for patience in advance.
I would like to install Hassio on it so that I can control my Lifx lights and Light strips for e.g. dim lights when playing media.

I have a

  • Raspberry Pi 2 Model B (I know it should only be used for testing)
  • 2 x WiFi Dongle
    Dlink DWL-G132
    Dlink DWA-110

Note: I do not have an available ethernet port, therefore, WiFi is a mandatory requirement).
FYI these dongles worked straight away when I plugged them in my Raspian OS

I have recently had success setting up Home Assistant Core onto Raspian and had the wifi working fine, however, I have just found out that it doesn’t have the add-on store(and doing some googling it has become apparent that it’s beyond my ability to set it up).

I have tried flashing Hassio onto an SD card and had Hassio working but it was only successful with an ethernet connection. I have tried the following methods:

  • the my-network/system-connections onto a USB drive option but it doesn’t work.

  • using nmcli to set a static IP address

Note I get a fw missing on wlan0 and was wondering if it means “firmware missing”

This is what happens when I try to plug and unplug the adapter

Can someone please let me know if it is possible and I would appreciate it if someone can point to me in the correct direction.

There is no driver available for the wifi adapter

Is there any solution? It works on raspian without any need to download the drivers

Hi,
Maybe you need to install the driver for your wifi dongle.
I had to do that with MoOdeaudio with a TP-link usb key and its chipset Realtek r8188eu.

  1. uname -a
    to find your system version

  2. download the version according to your system at http://downloads.fars-robotics.net/wifi-drivers/8188eu-drivers/

  3. sudo ./install

  4. reboot

I’m noob here. So I hope it’s the good way…

Hey Nickous

I did some digging around on your link and found out there were some instructions http://downloads.fars-robotics.net/. However how do I even install these when I flashed HASSIO without Raspbian? I’ve only got the Home assistant command line and access to the host system.

Attach a monitor and keyboard to your pi. Then you can login to the host to do the configuration.

I have connected a monitor and keyboard to my pi. I can see the Home assistant login screen and I can also access the host system. I do not know how to do the configuration.


I am trying to do what’s specified at the end of this webpage
http://downloads.fars-robotics.net/ but I do not have NOOBS or Raspian. When I try to use the wget, i get “/bin/ash: wget: not found”

I just followed these instructions here to isntall HASSIO on my SD card https://www.home-assistant.io/hassio/installation/

Did you figure out how to install the driver?