Hassio share directory access

I have a folder called motion in the share that I wish to access, so I’ve added the following to my config:

    - /share/motion/

However I receive the error:

Invalid config for [homeassistant]: not a directory @ data['whitelist_external_dirs'][0]. Got '/share/motion/'. 

But this is definitely (?!) a valid directory:

Any advice?

Hi. I justed used «share» and rebooted. Then it worked :slight_smile:

@Rune can you post the relevant config? I’ve not seen << >> before

Hi. Sorry. Thats correct no “” needed. I used the config below and rebooted, It will tell you that this is wrong too, but after a restart it worked for me.

    - /share/

Interesting about the error. Will try tonight. Cheers!

Finally home from work. I noticed that my config didn`t match 100% so here you go:

    - '/share/'
1 Like

With that I get:

Invalid config for [homeassistant]: not a directory @ data['whitelist_external_dirs'][0]. Got '/share/'

Try removing the / at the end and see… try:

    - '/share'

does /share actually exist INSIDE the home assistant container?

1 Like

Same error with '/share'

I am able to do the following, so pretty certain share is accessible, and this is a config or permissions

 - platform: command_line
    name: new_image
    command: "ls /share/motion -Art | tail -n -3 | grep 'capture.jpg'"

Did you reboot or just restart hassio?

The error says - Invalid Config. I don’t think it is even checking for whether the folder exists or not. I’d double check the indentation and spacing issues. Yaml can be a PITA.

I got an invalid config regardless… I rebooted and it worked with my config given above. Why? I don`t know :slight_smile:

Ok, after rebooting the host ‘/share’ does work. Will create an issue on Github

1 Like

I tried to include the www directory in the whitelist (my first attempt at a whitelist entry) but it caused HA to not boot. I was doing this to try and fix my issue with getting the HTML5 component set up. Any idea what my issue could be? there was nothing in the log as to why it didnt load after a power cycly. I had to # out the lines via SSH and power cycle again to get back online.


  # Name of the location where Home Assistant is running
  name: Home
  # Location required to calculate the time the sun rises and sets
  latitude: -xx.8860
  longitude: 1xx.9230
  # Impacts weather/sunrise data (altitude above sea level in meters)
  elevation: 16
  # metric for Metric, imperial for Imperial
  unit_system: metric
  # Pick yours from here: http://en.wikipedia.org/wiki/List_of_tz_database_time_zones
  time_zone: Australia/Perth
  # Customization file
  customize: !include customize.yaml
  #package setup
  packages: !include_dir_named packages
    - /'www'

You need

    - /www

cheers! I’ll give it a try

so as per your previous post regarding the need to power cycle, would that be why…

…fails the config check??

There is a fix for an issue that resolves this, should be merged soon

cool. but a power cycle should work without crashing it? (I will be getting my girlfriend to power cycle since I’m away and therefore cant sort it out locally if it fails!)