Hassio stopped working (without reason)

Hi there,

Please, please, please, help! I’ve been using HA (on a Raspberry Pi) integrated with Nabu Casa, without any problem, for more than a year now. Few lights, my music equipment, the swimming pool filter, the garage doors… everything almost perfect.

Last night, it stopped working, without any apparent reason, and without giving any sign whatsoever. I tried rebooting it, and it does nothing. The only thing I could check was that my router is actually assigning its IP address correctly.

I also tried using ssh, but nothing seems to happen either. And it is not shown on the local network for samba access.

What can I do??? Please let me know of any suggestions.

Your help would be greatly appreciated.

Sincerely!

MO

Clean install on a new SD card and restore your latest snapshot.

Uh. Ok. Will have to try this, then I guess!

One question, though: is the snapshot online, or I will have to get it from the current sd card???

Thanks!!

That would depend on how you do your backups.

Same thing happened to me last night at about the same time. Hub activities are still working (USB Z hub, sensor hub, still work - automation works from door sensor to light switch). but can’t access the IP, tileboard is down. It came back up for a few minutes last night then back down again. What is going on?? how can the same exact thing happen to us at the same time? something weird happened.

1 Like

I don’t seem to remember it, Tom. The standard way, I guess…

Problem is I could not access the sd card content, using a card reader on my Macbook. It doesn’t seem to recognize its filesystem. Is this alright???

Thanks again!

Your SD-card is corrupted. I hope you have backups not on the SD-card.

This is not the same at all. Your frontend has a problem. Here we have a completely stopped system. Even applications running in seperate containers (ssh) aren’t working.

Yup, a router reset did the trick for me. Super strange, it didn’t want to route me to HA for some reason. Gremlins in the Xfinity router.

I could read it on my linux setup.

Where should the snapshot be, exactly???

I’ve had access to the old sd card, using a linux setup… where should I look for the saved snapshot file??

Please advice on how I can recover it from the old card, and copy/move to the new installation.

Thanks a lot!!

If you are using home assistant supervised, they are in /usr/share/hassio/backup. If you are using home assistant OS, I don’t know.

One other question… I had my home assistant connected to Nabu… no backup snapshot over there?? Excuse how naive I might sound… but was hoping there might be a way to find the backup online somewhere!

There are some add-on that upload your snapshots to google drive , Dropbox, … There is an add-on that uploads your snapshots to a samba share. But of course you need to use one of these.

After following the directions here: https://unix.stackexchange.com/questions/509973/mount-ext4-disk-cannot-mount-dev-sdc-read-only

…was able to find two .tar backup files (I guess and hope!).

I’ll try putting them on the same directory within the new sd card. Will let you know.

Got the files on the new sd card, and was able to “restore” de snapshots… the web interface is not alive yet, although I was able to access the samba share… a (good) beginning, I’d say.

I’m rebooting now.

Samba is available, but the web interface is not.

What could I try now???

Thanks, again!

It seems to be back online… but no configuration files were restored. No home-screen, no automation, no much.

Is there something else I should try??

I had my system shit it’s self too several weeks ago (power went out came on, all good, went out again then again a 3rd time during reboot corrupted files I guess🤬) I bit the bullet and just re did it all again with a fresh install. was faster than trying to recover it in the long run.

As soon as I was done getting back to my former state I made an image of the SD card and swear I’ll take more frequent snapshots.