HassIO stops responding every so often

What are the conseguences of deleting the DB?

You lose your history data

The same for me! My HASSIO is often going to reboot at 3:30am (UTC+3).
My HASSIO installation is very tiny, I just start to use it for my home automations. There are some ESPHome devices, a few Node Red flows, and a typical core HA. So I suspect some recurring core routine as a root of the problem.
I’m a professional linux/web developer, but unfortunately, It’s not easy to analyze HA logs and HA state without a diving into architecture of it’s core.

1 Like

Also for me.
A new installation, no more then 2 weeks. Already happened 2 times during the night. No erros, nothing.

Someone with some clue, what we can do?

Thanks.

So many reporting that HA hangs after less than 24 hours.(into various areas iof the forum)
Several attempts good suggestions to remedy but without result.
Why is nobody taking this serious, as it has been going on for a long time?

2 Likes

After getting a new rpi original power supply and flash a new A2 SD card, I was still having this “freezing” issue. Recently, I have discovered that the problem might be with one add-on I use. After uninstall this addon, no more problems.

I have commented on a github issue, where other people is having the same problem:

PS: Definitely, this is not everyone case, but it is another clue to dig into.

I would like to add my 50 cents. I am experiencing precisely the issue described here. Hassio on RPi4, conncted via ethernet, using the Electrolama Zigbee stick (latest drivers). A very basic setup - running six lights with Ikea switches through ZHA. That’s the only integration plus HACS for frontend stuff with ControllerX. The Hass is configured for RPi fan control and to track two phones via Wi-Fi ping.

I am experiencing very irregular unresponsiveness from the RPi, it takes from hours to several days between each event. This has been going on for several months, before it was completely fine. Everything is updated to latest versions.

I have already tried to move to another SD card (unfortunately class 10), create a new installation, monitor IO of the CPU as suggested, nothing seems to be the case. When looking at the RPi itself during the unresponsiveness, the green LED at the ethernet port blinks very rapidly and very regularly (normally, this is very random and happens slowly), the device itself gets hotter than usual (the connected fan does not trigger). Phone app can’t conect. The only remedy is to plug it out and in, after that in runs fine. This basically renders Home assistant unusable for me as I can’t really rely on anything, even on basic lighting.

Any way of logging or troubleshooting this would be greatly appreciated. I am going to start disabling addons starting with HACS, but I reckon this is quite a deeper problem in HA - everybody is desribing different remedies to the same problem. Thank you very much.

1 Like

I have the same configuration, but instead of having an SD card I have my Homeassistant on SSD.

Before I had configured everything on Debian Buster, I thought it could be an installation problem and migrated everything to HassOS. but the problem persists.

Now purge the DB to see if it stops doing it.

Apologies for my bad English.

It also happens to me that 3.30AM stops responding. At the time I thought it could be some automation. but now that I read what happens to them at the same time, I think it could be something else.

Could you find a solution?

Suddenly my solution ran for almost48 hours without crashing but the day after it stopped twice within 24h.

I have tried almost everything.
New SD, New Raspberry PI, checked memory, temperature, CPU load, reduced number of integrations.
No help

Seems like many have the same problem and it existed for a loooong time.
Rebooting every 6 hours is not an acceptable option.
Does anyone have an idea, how we can escalate this?

I’m having the same problem with RPi 4, SSD setup. I have tried disabling various plugins, addons, restarting nightly and changing the recorder config. I still get random freezes every few days and sometimes within 24 hours of unplugging/replugging. As @JanRoman mentioned, I am also seeing “the green LED at the ethernet port blinks very rapidly and very regularly” when this happens.

At my system it was able to kill my router completely. All lan ports and wan port went down. The pi4 also became totally irrisponsive, blinking the network port like crazy.
In the end I did try for a few days to remove the cap so a little more cool air came at the pi board. Perhaps you can try that too. But did not wait for another crash.
After 2 weeks struggle I decided to move to a nuc. Having a very stable system.
I hope you can find the answer.

And after upgrading to SSD and adding more air do even decrease temperature. Same issue.
Dows anyone have a good idea on how we can increase the priority on this topic?
Why are only some having this?

Did you find the solution? I have exactly the same problem as you.

Ok, as suggested by a few others on this thread, I did a completely fresh install of HA and did not restore from a Snapshot. So far, it has been stable! It is a bit of a pain setting everything up again by hand but I did extract one of the snapshots locally and search through it for settings config, etc. to make the setup easier. Although it’s a pain, having HA lock up every 24-48h is definitely more of a pain.

Another variable at play is that when I set things up again, I used the Z-Wave JS Integration rather than the old Z-Wave one. I have an unconfirmed suspicion that old integration was causing issues but I do not know for sure.

2 Likes

Im having the same problems but dont use z-wave at all… have tried stripping most of the add-ons but cant figure out any source of the problem. :frowning:

Have you tried a completely fresh install without restoring a snapshot?

I have tried restoring a snapshot, and even a fresh install. I don’t think it is a problem of HA itself, but I believe it is some kind of low level Hass OS problem as there simply is no pattern to it whatsoever. Is there anyone on Debian for instance experiencing something like this?

I’m having this issue too…
Normally i wipe the DB and its ok again but now no luck wiping the db
The system goes unreachable after x time

What should i do?

Yesterday evening, all was ok, this morning had to reboot
Fine for an hour, now back to unreachable :frowning:
Pls
Help me :slight_smile:

Hi.
I’m facing the same issue since about 2 weeks, RPI 3B+ and SSD on USB.
Everything started after installing Esphome, but I’m not sure that things are related.