HassIO stops responding every so often

Same issue, running RPI3 HassIO.
What should have been a fun project has become a nightmare.


I suggest moving away from SD cards for a start. Yes the RPi is ‘suggested’ in the docs, but that is purely to people a way of getting into HA for very little financial investment.

Perhaps you are following extremely outdated YouTube videos from when Home Assistant was still called this? It hasn’t been HassIO for something like 18 months or more. Anything you watch or read that still calls it this is surely not accurate enough to still use and will likely cause you trouble.

I followed the latest and greatest installation procedure for RPI, i just assumed it was Hassio.

I even tried to install HA on Debian 10, but the behaviour was exectaly the same. RPI 3 became frozen in matter of minutes or few hours.

However, long story short, i went ahead and got myself a brand new Raspberry Pi 4 - 8 GB with a decent SD card, and installed everything from scratch again, and it has been running fine for almost 3 days now, smooth as butter, (knock the wood) :slight_smile:

Im currently running these apps:

  • MotionEye
  • Node-Red
  • HACS for new theme.
  • Grafana
  • Nginx
  • VS code.


1 Like

Nah, HassIO hasn’t existed (as that name) for a long time. Long story short, its’ the same product but a new name, now simply called Home Assistant.

Unfortunately we still keep getting people use the old name in forum posts.

1 Like

I am experiencing the same problem with a Raspberry Pi 4b 4GB with an application class 2 SD card. Home Assistant no longers serves the UI over port 8123, and I cannot ping the device on the local network. Connecting a HDMI cable and keyboard to the Pi reveals that the system is indeed online and I can process commands (like host reboot which fixes the problem). Is there some sort of log file I can sift through to see what might have happened during the time when it became unresponsive? Did the web server crash? Or was it something more sinister…

1 Like

Couple of ways to see log data from the terminal:

  • dmesg => reavels kernel diagnostic info.
  • cat /config/home-assistant.log => HA Logs
  • top => CPU and Mem usage.

Worth a shot
But all these will be wiped out on boot, so you should try to read these files while the system hangs.

Thanks for the advice. I did have the problem again today and only thought to check back here after the fact.

This time I had it slightly different, the UI would respond okay, but every integration had stopped working. Logs seemed to indicate some type of network error that I failed to make a note of. I thought I’d try to restart using the web interface using Configuration → Server Controls, but the instance never came back online. I rebooted from the terminal and it seems okay again now.

I am sure this will happen again in a few days, so I’ll try to run those commands on the box to see what it shows.

Just for the record.
After MANY months of problems with state of the art RPI4 setup and all sorts of reinstall etc. I finally decided to run in on an older Intel NUC - No problems ever since.

1 Like

This is definitely HassOS related (at least using RPi4). As many other users reported, all problems stopped after migrating from HassOS to Debian. I even restored the backup, no problem whatsoever.

1 Like

I’m going to try flashing Debian to the SD card and reinstalling Home Assistant instead of using Home Assistant OS then to see how that goes. It’s just stopped working on me again and not providing me with any meaningful reason why. I can see that my Internet connection dropped out during the night but that’s it.

I was having this issue on RPi4 with Docker HA installation. I moved to HA OS, and still am having this problem every couple of days. So I don’t think it’s specific to HA OS.
It was even more annoying for me since I ran Adguard on the Pi, and my whole home internet would go down. I moved Adguard to a different device, to at least not affect my home internet.

I do have Deconz like some of the others here, but there’s no sign or CPU or RAM overload prior to the freezing happening.

Things I want to try to pinpoint the culprit:

  • SSD instead of SD Card
  • Move Deconz to another device

After 2 month of daily freezes I reinstalled the Pi3, did not restore the backup. I added deconz and all other integrations and build everything up from scratch again, I have alot of integrations and stuff so it took some time. I have now had 5 days in a row without any problems so there must be something with the continuous upgrades over time that causes the freeze’s. So try rebuild without restoring the backups.

1 Like

There seem to be two, possibly unrelated, issues in the thread. Most people experience Home assistant to become unresponsive (web, ssh) but still running. The other issue is system crashing or restarting.
I experience the former on RPi3B, HA only runs for less than a day before hanging, sometimes it only takes hours. It started after I made several changes to my setup - switched from SD card to SSD, added zigbee dongle (cc2531), installed influxdb and grafana. Before it ran without a hick up for years.
After many attempts and ruling out both mentioned addons and the dongle itself, my best bet is on memory. Possibly a memory leak somewhere as the root cause. This is what I see: Screenshot_20210624_000742
In my case, each spike corresponds to the HA hanging.
I checked the swap and as expected, it was at 100% all the time. After consulting How can i increase my swap file size? · Issue #968 · home-assistant/operating-system · GitHub and How to increase the swap file size on Home Assistant OS, I increased the default 227MB to 2GB. A day later, with all the addons running the swap stabilised on 400MB and the memory on 70% with occasional spikes to 80%. No issues so far, it’s running fine. I don’t want to be overly optimistic but I think I found the culprit.
If you’re hitting the same issue as me, try increasing swap size (on ssd disk! Not a great idea if using SD card). For a more robust solution, upgrade to RPi4 with 4GB/8GB RAM or Intel NUS with 4GB+ RAM.


I add my 50 cents too. I was experiencing the same issue for several weeks without knowing what to do. I remarked that the temperature of my raspberry pi 4 was pretty high. So I bought on amazon a case with a passive cooling system, and for now, it’s ok.
So if you are experiencing the same as me, double check if your raspberry pi is not overheating. I hope my experience could help :slight_smile:

I did a fresh install of 6.1 on an SSD and again on a SD Card of a Rpi4, 4 Gb Ram with the same results as above. After a day HASS becomes intermittently unresponsive. The monitor and keyboard on the Pi are still responsive and the RPi will respond to pings. It returns to functional in time, but I don’t see anything in the logs. The only addons I have running are MQTT Broker, MQTT Integration, and Tasmota Devices Integration. I found multiple posts describing this behavior in different ways and a lot of users struggling with it with no conclusive answer. Where do I go from here? The power levels are good, (RPi official power adapter), and the temperature of the RPi is good as well.

I believe this is some sort of low level problem, happening in certain hardware/software/configuration combinations. Most users are using RPi 3/4, but I believe I have already seen this complaint using Intel NUC (may be a different problem though). Considering high amount of variables involved, it is going to be hard to solve.

From my experience, I recommend trying another operating system - change from HassOS to Debian or from Debian to HassOS. It does not take long and is worth the shot. I am in peace ever since.

ive also now been getting lockups on my i5 nuc, it has 8gb ram and 128gb ssd running only homeassistant image no docker.

it just wont let me into the interface and i have to then pull power and then plug back in.

looking at my cpu and mem usage it seems the mem usage starts to creep up and then hits 100% locking up the nuc, it seems to happen randomly say 3-6days its only started to happen the past 2 months

you can see exactly where it crashes and when the memory started to creep up

I’ve been having the same issue for some time. It started to happen 2-3 months ago. Yesterday I formatted my SD card and did a completely new installation and left it with nothing on it. Just the basic installation of the Home Assistant Operating System. Everything worked fine for 4-5 hours then it was completely frozen again.

I’m running a Rasperry Pi 4 8GB. Like everyone else in this thread I could not see any kind of problems in the CPU/Memory/Disk sensors before reinstalling.

I think that I’m giving up on the Home Assistant Operating System and will try another solution.

What SD card are you using? The issue has nothing to do with HA OS, it’s most likely hardware. I run HA OS on a NUC and it NEVER crashes. My previous RPi install did crash every so often until I swapped the SD.

I’m using an A2 card from SanDisk. Anyway, when I did my clean install I forgot that I still had my Conbee stick attached. It’s now detached and the system has been running since. Hopefully there’s something wrong with it. I will check all other hardware as well.